[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Pkg-xen-devel] Bug#588839: pv-grub removed ?

On Sat, 2010-10-02 at 02:49 +0800, Thomas Goirand wrote: 
> Philipp Kern wrote:
> > On Fri, Oct 01, 2010 at 03:56:13PM +0800, Thomas Goirand wrote:
> >> Now, I hope someone from the release team will answer this: if we build
> >> a new xen-pv-grub package, will it be accepted by the RT, even if we are
> >> late, as the lack of pv-grub in the xen-utils can be considered a
> >> regression in Squeeze (as Lenny had the feature)?
> > 
> > AFAICS there was no pv-grub in Lenny:
> > 
> > pkern@franck:~/ftp/ftp/dists/lenny$ zgrep pv-grub Contents-amd64.gz Contents-i386.gz
> > pkern@franck:~/ftp/ftp/dists/lenny$
> > 
> > If this is the case, there's no regression.  Furthermore this is a bug of
> > severity:wishlist, so no, it would be too late for this.
> > 
> > Kind regards,
> > Philipp Kern
> Considering that here:
> http://wiki.xensource.com/xenwiki/PvGrub
> it's written that PvGrub is replacing pygrub,

Replacing is rather strong. They serve similar purposes but its entirely
up to user preference and/or requirements which one is used. They
certainly aren't mutually exclusive or anything like that and pygrub is
not going away upstream any time soon.

> and that in Lenny (unless there's still pygrub in Squeeze,

pygrub _is_ in squeeze:
$ dpkg -S /usr/lib/xen-*/bin/pygrub
xen-utils-4.0: /usr/lib/xen-4.0/bin/pygrub

I haven't seen any suggestion, from Bastian or otherwise, that it will
be removed.

I don't believe pvgrub was in Lenny.

Ian Campbell

TOO BAD YOU CAN'T BUY a voodoo globe so that you could make the earth spin
real fast and freak everybody out.
		-- Jack Handey, The New Mexican, 1988.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: