[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

flpsed stable update required


The bug #517521 was filed by me today based on a report sent directly
to me on 4th February 2009. Unfortunately, I didn't see it until
recently so lenny has got "flpsed" with an RC bug.

The problem is as follows. "flpsed" uses the "x11alpha" driver of
"gs" to create a view of the postscript page that is being annotated.
Hemce, the package needs to depend on "ghostscript-x" whereas version
0.5.1-1 (in lenny) depends only on "ghostscript".

The (tiny) patch that fixes this is enclosed. Please let me know if
it is OK to upload 0.5.1-2 with this patch to "stable".



diff --git a/debian/changelog b/debian/changelog
index 904eafb..3bb227e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,3 @@
-flpsed (0.5.1-2) stable; urgency=medium
-  * debian/control: replaced "ghostscript" dependency with
-    "ghostscript-x" since we use "x11alpha" driver.
-    Closes: #517521.
- -- Kapil Hari Paranjape <kapil@debian.org>  Sat, 28 Feb 2009 22:24:34 +0530
 flpsed (0.5.1-1) unstable; urgency=low
   * New upstream release (0.5.1)
diff --git a/debian/control b/debian/control
index 2da0bf8..ad7fa5e 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Standards-Version: 3.8.0
 Package: flpsed
 Architecture: any
-Depends: ghostscript-x (>= 8.62.dfsg.1-2.1), ${shlibs:Depends}, ${misc:Depends}
+Depends: ghostscript (>= 8.62.dfsg.1-2.1), ${shlibs:Depends}, ${misc:Depends}
 Recommends: xpdf-utils | poppler-utils
 Description: a WYSIWYG pseudo PostScript editor
  flpsed is a WYSIWYG pseudo PostScript editor. "Pseudo", because you can't

Attachment: signature.asc
Description: Digital signature

Reply to: