[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Freeze exception request for twyt


I would like to request a freeze exception for twyt (python-twyt)
0.9.0-1 (current in Lenny: 0.8.5-1).

I realise there are restrictions on unfreezing packages where there are
substantial upstream changes. However, the Twitter API has changed
substantially since twyt 0.8.5 was released and has effectively
obsoleted 0.8.5.

So, leaving 0.8.5-1 in Lenny would just attract unnecessary grief and
bug reports. In my opinion, 0.9.0-1 is a much better candidate for
inclusion in Lenny, despite the number of non-trivial changes between
0.8.5 and 0.9.0.

If it cannot be unfrozen due to upstream version change restrictions,
could it be removed from Lenny entirely? There are currently no packages
which depend on it.


twyt (0.9.0-1) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn

  [ Andy Price ]
  * New upstream release
  * Update Standards-Version to 3.8.0
    - no packaging changes needed
  * debian/control
    - add ${misc:Depends} as a dependency
    - remove 'An' from short description
  * debian/docs
    - update GUIHOWTO to HOWTO to reflect upstream rename
  * debian/copyright
    - update year to 2009

 -- Andy Price <andy@andrewprice.me.uk>  Sun, 11 Jan 2009 05:51:20 +0000


Andy Price

Reply to: