[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#503712: the gs-common problem

Thomas Viehmann wrote:
> So this is how an NMU choosing the include hack in .config route would
> look like.
> I'm not quite convinced that this is actually better than having
> ghosscript depend on gs-common, gs-common not depend on ghostscript-x
> and checking the reverse (build-)depends for breakage.
So build logs for (all but the one contrib) reverse build depends are
at[1]. All seem to succeed, two seem to build-depend indirectly
ghostscript-x (via transfig via gs-gpl, latex-mk via transfig).
I'll check the debs somewhat, too, but if we think that ghostscript
depending on gs-common and living with the circular depends solves the
problem, this might be a more conservative way to fix this for lenny.
Two maintainers of reverse dependencies have replied already that their
packages don't need ghostscript-x, leaving one with some breakage potential.

Given that there are two possible vectors with more-or-less
ready-to-upload packages, we should want to decide this soonish.
I'm leaning towards the dependency change a bit. Note that ghostscript
seems to be the only package conflicting with gs-common.

Kind regards


Thomas Viehmann, http://thomas.viehmann.net/
diff -u ghostscript-8.62.dfsg.1/debian/control ghostscript-8.62.dfsg.1/debian/control
--- ghostscript-8.62.dfsg.1/debian/control
+++ ghostscript-8.62.dfsg.1/debian/control
@@ -10,10 +10,10 @@
 Architecture: any
 Conflicts: gs (<< 8.62), gs-esp (<< 8.62), gs-gpl (<< 8.62), gs-afpl (<< 8.62), gs-aladdin (<< 8.62), gs-cjk-resource (<< 1.20010910-1), gs-pdfencrypt (<< 7.00), gs-common (<< 8.62)
 Replaces: gs (<< 8.62), gs-esp (<< 8.62), gs-gpl (<< 8.62), gs-afpl (<< 8.62), gs-aladdin (<< 8.62), gs-pdfencrypt (<< 7.00), gs-common (<< 8.62)
-Provides: gs-pdfencrypt, postscript-viewer, gs-common
+Provides: gs-pdfencrypt, postscript-viewer
 Recommends: psfontmgr
 Suggests: ghostscript-x, hpijs
-Depends: ${shlibs:Depends}, gsfonts (>= 6.0-1), defoma, debconf | debconf-2.0, debianutils (>= 1.6), libgs8 (= ${binary:Version})
+Depends: ${shlibs:Depends}, gs-common (>= 8.62.dfsg.1-3.2b), gsfonts (>= 6.0-1), defoma, debconf | debconf-2.0, debianutils (>= 1.6), libgs8 (= ${binary:Version})
 Description: The GPL Ghostscript PostScript/PDF interpreter
  Ghostscript is used for PostScript/PDF preview and printing.  Usually as
  a back-end to a program such as ghostview, it can display PostScript and PDF
@@ -65,12 +65,11 @@
 Package: gs-common
 Architecture: all
-Priority: extra
-Depends:  ghostscript, ghostscript-x
-Description: Transitional package
+Priority: optional
+Depends:  ghostscript
+Description: Dummy package depending on ghostscript
  This dummy package is provided for a smooth transition from the
  previous gs-.../gs-common combo (the packages are replaced by ghostscript).
- It may safely be removed after installation.
 Package: ghostscript-x
 Architecture: any
diff -u ghostscript-8.62.dfsg.1/debian/changelog ghostscript-8.62.dfsg.1/debian/changelog
--- ghostscript-8.62.dfsg.1/debian/changelog
+++ ghostscript-8.62.dfsg.1/debian/changelog
@@ -1,3 +1,12 @@
+ghostscript (8.62.dfsg.1-3.2b) unstable; urgency=low
+  * Non-maintainer upload.
+  * Make ghostscript depend on gs-common to prevent removal.
+    Drop gs-common -> ghostscript-x dependency to not force the
+    X version on all users.
+ -- Thomas Viehmann <tv@beamnet.de>  Sun, 28 Dec 2008 11:18:18 +0100
 ghostscript (8.62.dfsg.1-3.1) unstable; urgency=medium
   * Non-maintainer upload.

Reply to: