[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: seeking pre-approval for some perl bugfixes



Niko Tyni <ntyni@debian.org> writes:
> On Mon, Aug 04, 2008 at 08:02:44PM +0200, Marc 'HE' Brockschmidt wrote:
>> Niko Tyni <ntyni@debian.org> writes:
>>> #479957: Using IO::File together with POSIX causes warnings. (Constant subroutine main::SEEK_SET redefined) 
>>>  These warnings bother at least eximstat and xscreensaver users.
>>>  patch attached as 22_fix_constant_subroutine_warnings
>> I'm too lazy to check the patch context: Will this continue to allow
>> importing SEEK_CUR, S_IRGRP and friends from POSIX?
> Yes.

OK then.

> #479540: Warning when including perl.h 
>  The fix is trivial.
>  patch attached as 16_fix_perlio_teardown_prototype

OK.

> #480719: perl-modules: outdated libfile-temp-perl conflict 
>  Not strictly needed, I suppose, but shouldn't break anything.
>  patch attached as 480719.patch

ok

> #479434: perl: Getopt::Long with subs breaks in Perl 5.10
>  The fix for this regression is simple and would fix libvcp-perl FTBFS bugs
>  (#467343 and #479948)
>  patch attached as 13_fix_getopt_long_callback

ok

> #480533: "uninitialized value" warnings from Perl during install 
>  This bloats perl-base, but it's the right thing to do and the d-i people 
>  (at least Otavio) were quite anxious to get the fix in earlier. 
>  I'll have to check with them too, of course.
>  patch attached as 480533.patch

ok

Marc
-- 
Fachbegriffe der Informatik - Einfach erklärt
33: Echte NS-Lady
       Benutzerin von Netscape. (nach de.talk.bizarre)

Attachment: pgp76JGawdSpk.pgp
Description: PGP signature


Reply to: