[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please bin-NMU alsa-plugins

Hey vorlon,

On Tue, Jul 03, 2007 at 02:45:13PM -0700, Steve Langasek wrote:
> > Due to a bug in alsa-lib 1.0.14, any package building an ALSA-module
> > built agianst this version got its "plugindir" wrong, rendering the
> > plugins unusable.
> > 1.0.14a was uploaded short after and should fix the problem. Please
> > recompile alsa-plugins against libasound2-dev 1.0.14a-1, to close
> > #429730.
> Which architectures does this apply to?  Bug #429730 only mentions amd64.
> And is this problem due to a bug in libasound2 1.0.14 only, or is this a
> case of libasound2 breaking binary compatibility between 1.0.13 and 1.0.14
> that needs to be addressed in order to provide a clean upgrade path from
> etch?

This should apply to many other architectures, but I don't know if all
buildds built alsa-plugins against the new alsa-lib. Maybe some took the
old ones (there was a shlib bump, should be easy to find out).

And yes, the problem specifically was a typo in configure.in, where the
plugin dir was set to "plugindir" instead of /usr/lib/alsa-lib/, due to
a missing "$". This appeared in version 1.0.14-1 only, was resolved a
few days later in 1.0.14.a-1.

> This request has been on hold because alsa-plugins is implicated in the
> current library transition mess, but I'd like to resolve this ASAP once
> that's clear (which should be this weekend).

No hurries!

Jordi Mallach Pérez  --  Debian developer     http://www.debian.org/
jordi@sindominio.net     jordi@debian.org     http://www.sindominio.net/
GnuPG public key information available at http://oskuro.net/

Reply to: