[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Consider ocamlgsl_0.5.2-1 for etch

Hi Sylvain,

On Thu, Jan 18, 2007 at 09:38:20PM +0000, Sylvain Le Gall wrote:

> On 14-01-2007, Sylvain Le Gall <gildor@debian.org> wrote:
> > Hash: SHA1
> >
> > Hello,
> >
> > I have just uploaded ocamlgsl 0.5.2-1i to unstable. The former version
> > (0.5.1-3) has an important bugs, that this new upstream release fix. I
> > attach the diff between the two version.
> >
> > The difference is :
> > * Upstream correction of bug (#406711: libocamlgsl-ocaml-dev: undefined
> >   reference to `ml_gsl_sf_legendre_array_size_e' when building top level
> > * Use of ocaml.mk (shipped in ocaml package).
> >
> > Since the upstream correction solved a bug of severity important i think 
> > it should be good to correct this for etch.
> >
> > Dependency in etch are enough for this new package. 

> As suggested, i have rebuild a package 0.5.2-0etch1 which doesn't have
> the "build system maintainance". Now it includes only the new upstream
> release.

> I would like to upload this package to testing-proposed-update. 

> Is this OK ?

Testing-proposed-updates is intended for RC bugfixes, and definitely not for
new upstream releases.  If you want to see this fix included in etch, please
provide a package via unstable that includes the important bugfixes without
the build system reorg, and reintroduce the build system changes after it's
been accepted into etch.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: