[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#316031: libfreetype6: API changes from 2.1.7 to 2.1.10

On Tuesday 28 June 2005 06:14, Steve Langasek wrote:
> On Mon, Jun 27, 2005 at 10:29:55PM -0500, Ming Hua wrote:
> > So from my understanding, it's urgent for libfreetype6 to bump its
> > shlibs from "libfreetype6 (>= 2.1.5-1)" to "libfreetype6 (>= 2.1.10-1)".
> No.  See bug #314385:  this library package's *name* needs to change,
> because of the issue you describe below.

It looks like this is the case, I had hoped that the incompatibilities were 
minor enough that it would be possible to add any missing APIs back in where 

I had prepared an upload that fixed the s/Lookup_Size/LookupSize/ issue, but I 
was not aware of the Mozilla problems.

I think the best thing to do is add a freetype2.1.7 source package that builds 
libfreetype6 with an epoch and coordinate with upstream the change to the 
soname - the next release looks like it is meant to break the ABI (more than 
normal that is).

Does that sound reasonable? I'd rather not epoch the package but I don't see 
any other choice here.

Reply to: