[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#316031: libfreetype6: API changes from 2.1.7 to 2.1.10

Package: libfreetype6
Version: 2.1.10-1
Severity: important

Hi Will,

I am filing this bug to raise your attention about the API changes in
libfreetype6 from 2.1.7 to 2.1.10.  Due to the large extent it may
affect, I am also cc:ing debian-release.

FreeType 2.1.7 was released on November 2003, and Debian stuck to this
version for quite a while.  Recently Will take over freetype and
uploaded freshly released 2.1.10.

However, there are substantial API changes from 2.1.7 to 2.1.10.  For
example, a series of functions to control font emboldening are
implemented in 2.1.10 [1], and XFT 2.1.7 were already using them if they
are available.  The libxft 2.1.7-1 currently in sid are compiled against
old libfreetype6 2.1.7 so those features are not enabled.  However, if
libxft2 is rebuilt against sid right now, those features will be enabled
and if the new libxft2 is used with old libfreetype 2.1.7 (for exapmle,
the one in sarge), there will be unresolved symbol errors.

So from my understanding, it's urgent for libfreetype6 to bump its
shlibs from "libfreetype6 (>= 2.1.5-1)" to "libfreetype6 (>= 2.1.10-1)".

A more serious problem, though, is that FreeType 2.1.10 dropped some old
APIs.  I didn't follow freetype development, and the CHANGES
documentation in freetype aren't very clear either.  Therefore I don't
know if these APIs were private, or deprecated long ago, or anything
else.  But them being dropped are causing many new problems.  The ones I
am aware of right now are:  (1) mozilla-firefox FTBFS [2] on new
libfreetype6-dev because it uses old FTC_Image_Cache_* API (superseded
by FTC_ImageCache_*).  (2) gworkspace.app get undefined symbol
FTC_Manager_Lookup_Size while using new libfreetype6 [3].

So how should we deal with this issue?  I can't find a comprehensive
list about what APIs are dropped from 2.1.7 to 2.1.10, and even if we
have such a list, it's still hard to figure out which packages are using

I hope we deal with these two issues as early as possible (especially
the first one, as more and more packaged are built with new
libfreetype6-dev).  I still remember the big headache libtiff API change
caused before sarge release, don't let it happen again for etch.

1. http://lists.gnu.org/archive/html/freetype-devel/2005-06/msg00068.html

2. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=314243

3. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=314385


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.8-2-k7
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages libfreetype6 depends on:
ii  libc6                       2.3.2.ds1-22 GNU C Library: Shared libraries an
ii  zlib1g                      1:1.2.2-4    compression library - runtime

libfreetype6 recommends no packages.

-- no debconf information

Reply to: