[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kdebindings and libqt-perl uploads (#274779 and #274989)

hi all,

  here is my proposed plan to fix these two RC bugs. note that for
  kdebindings this will mean sponsored maintainer uploads (see #274816
  against wnpp), and for libqt-perl somebody will have to NMU with the
  patches I'm providing (if they are regarded correct, of course).

  I've had the opportunity to discuss it with Riku Voipio, who will
  sponsor my uploads and NMU libqt-perl if the Release Team is ok with
  the plan.

                                 * * *


  briefly, the situation is as follows: we have #274816 regarding a file
  conflict between libqt-perl and libsmokeqt{1,-dev}, since libqt-perl
  includes it's own copy of libsmokeqt. Matthias Klose tried to rebuild
  using the libsmokeqt{1,-dev} as Build-Depends, but since QT 3.3
  entered sarge these are broken:

    $ cat smoke.cpp
    #include <kde/smoke.h>

    int main ()
        Smoke::Index i;

        return 0;

    $ g++ smoke.cpp -lsmokeqt
    /usr/lib/gcc-lib/i486-linux/3.3.4/../../../libsmokeqt.so: undefined reference to `QTableItem::content() const'
    collect2: ld returned 1 exit status

  so using the current libsmokeqt packages from kdebindings 4:3.2.3-1 is
  not possible. anyway, a kdebindings upload to t-p-u (*) is necessary to
  fix #274989, which Matthias himself discovered while trying the above.

    (*) t-p-u and not unstable because of kdelibs4.

  so, my proposed solution is to make the kdebindings t-p-u upload
  first, and include in the libqt-perl one a tight enough B-D.

  however, as version in sid must be greater than version in sarge for
  t-p-u uploads to be accepted, kdebindings and libqt-perl uploads to
  unstable must happen first.

                                 * * *


    (1) First, kdebindings 3.3.0-1 is uploaded to unstable. This upload
        fixes #274989 (libsmokeqt-dev not depending on libsmokeqt1)
        *and* carries a Conflicts: libqt-perl (<= 3.008-1) in the
        offending packages.

    (2) libqt-perl 3.008-1 gets NMUed with this patch [1], and version
        3.008-1.1 is uploaded to unstable. Sample resulting .deb at [1b].

          [1]  http://www.alu.ua.es/a/asp16/tmp/NMU-SID-libqt-perl
          [1b] http://www.alu.ua.es/a/asp16/tmp/libqt-perl_3.008-1.1_i386.deb

    Once these uploads are installed, t-p-u uploads can follow:

    (3) kdebindings 3.2.3-2 gets uploaded to testing. The source is:


        The (small) interdiff wrt 3.2.3-1 is attached for RM review.

    (4) libqt-perl 3.008-1 gets NMUed again with this second patch [2]
        and 3.008-1+sarge.1 is uploaded to t-p-u. The patch is the *same* as
        [1], except for the version and the target distribution.

          [2]  http://www.alu.ua.es/a/asp16/tmp/NMU-sarge-libqt-perl

                                 * * *


    kdebindings 3.3.0-1 needs NEW processing (*). I'm not sure if
    uploading is enough for t-p-u uploads to be accepted or the packages
    must actually be installed (I guess the second).

      (*) It introduces the libkorundum0-ruby1.8 and libqt0-ruby1.8
          packages, and does not longer produce the obsolete libkdec1
          and libqtc1 packages.

    libqt-perl 3.008-1.1 will not be compilable until NEW processing
    happens and libsmokeqt-dev 3.3.0-1 gets installed. as it may be
    worth uploading quickly to permit the t-p-u upload, the NMUer could
    be given permission to use libsmokeqt-dev 3.3.0-1 and temporarily
    break installability of libqt-perl *in* *sid*.

    please some RM comment the above paragraph and recommend an upload
    date for #3 and #4 (t-p-u uploads).


Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621
Everything you read in newspapers is absolutely true, except for that
rare story of which you happen to have first-hand knowledge.
                -- Erwin Knoll
diff -u kdebindings-3.2.3/debian/control kdebindings-3.2.3/debian/control
--- kdebindings-3.2.3/debian/control
+++ kdebindings-3.2.3/debian/control
@@ -1,9 +1,9 @@
 Source: kdebindings
-Build-Depends: binutils-dev, debhelper (>> 4.0.0), gawk, gettext, gij, gcj, libgcj4-dev, fastjar, kdelibs4-dev (>= 4:3.1.4), libglib1.2-dev, libgtk1.2-dev, python2.3-dev, perl (>= 5.6.0-16), libqt3-compat-headers, sharutils
+Build-Depends: binutils-dev, debhelper (>> 4.0.0), gawk, gettext, gij, gcj, libgcj4-dev, fastjar, kdelibs4-dev (>= 4:3.1.4), libglib1.2-dev, libgtk1.2-dev, python2.3-dev, perl (>= 5.6.0-16), libqt3-compat-headers (>= 3:3.3.3), sharutils
 Section: devel
 Priority: optional
 Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
-Uploaders: Dominique Devriese <devriese@kde.org>
+Uploaders: Dominique Devriese <devriese@kde.org>, Adeodato Simó <asp16@alu.ua.es>
 Standards-Version: 3.6.1
 Package: kdebindings-java
@@ -130,7 +130,7 @@
 Package: libsmokeqt-dev
 Architecture: any
 Section: libdevel
-Depends: ${shlibs:Depends}
+Depends: libsmokeqt1 (= ${Source-Version}), ${shlibs:Depends}
 Description: Scripting Meta Object Kompiler Engine - binding library to Qt development files
  This library is used by various KDE language bindings packages to provide
  interfaces to the Qt and KDE libraries. This package contains the development
diff -u kdebindings-3.2.3/debian/changelog kdebindings-3.2.3/debian/changelog
--- kdebindings-3.2.3/debian/changelog
+++ kdebindings-3.2.3/debian/changelog
@@ -1,3 +1,13 @@
+kdebindings (4:3.2.3-2) testing-proposed-updates; urgency=low
+  * Upload to sarge to fix #274989 and make fixing #274779:
+    - rebuild against QT 3.3 (tightened Build-Depends version).
+    - make libsmokeqt-dev depend on libsmokeqt1.
+  * List me as uploader for this not to be taken as a NMU (which is not).
+ -- Adeodato Simó <asp16@alu.ua.es>  Thu, 07 Oct 2004 19:58:25 +0200
 kdebindings (4:3.2.3-1) unstable; urgency=low
   * New upstream version.

Reply to: