[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Uninstallable Packages

On Wed, Dec 31, 2003 at 04:10:22AM +0900, ehikory@mail.goo.ne.jp wrote:
> I wrote:
> >     Also, the "testing problems" output seems overzealous in marking
> > packages uninstallable, as I was able to sucessfully simulate installation
> > (sudo apt-get -s install foo) of the following, regardless of their also
> > being listed as uninstallable on eleven architectures, including my own.
> > 
> > odontolinux (0.6.1-7)
> > phppgadmin (3.2.1-1)
> > sourceforge (2.5-37)
> Colin Watson wrote:
> > The output seems quite correct; all of these packages depend on
> > php4-pgsql, which is indeed uninstallable in testing, since it needs a
> > newer version of php4. You must have a newer version of php4 installed
> > locally.
>     I have no version of php4 installed locally.  The version of php4-pgsql
> in testing (3:4.1.2-4) depends on zendapi-20010901, which is provided
> by either php4 4:4.1.2-6 in testing, or 4:4.1.2-6woody3 from the stable
> security archives, both of which are installable on my system according
> to apt.

Ah, I got the reason wrong. Here's output from a testing machine I run:

  $ sudo apt-get -s install php4-pgsql
  Reading Package Lists... Done
  Building Dependency Tree... Done
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.

  Since you only requested a single operation it is extremely likely that
  the package is simply not installable and a bug report against
  that package should be filed.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
    php4-pgsql: Depends: libpgsql2 (>= 7.2) but it is not installable
  E: Broken packages

libpgsql2 is only in stable, no longer in testing.

> If not an issue with the testing problems script, perhaps with
> the apt-get -s install dependency analysis?

Let me suggest a slight variation on my original guess. :) Do you still
have libpgsql2 installed?


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: