[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#584739: kontact: Kaddressbook component does not manage to connect with akonadi

Package: kontact
Version: 4:4.4.4-1
Severity: important

When starting kontact and switching to the kaddressbook component, "Akonadi not 
operational" always shows up, the underlying cause being that supposedly no agents 
are found ($XDG_DATA_DIRS is set to "/usr/share/:/usr/share/akonadi/agents/").
Shutting kontact down and doing "akonadictl stop && sleep 10 && akonadictl start", 
followed by restarting kontact fixes the problem.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (800, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kontact depends on:
ii  kdebase-runtime               4:4.4.4-1  runtime components from the offici
ii  kdepim-runtime                4:4.4.4-1  Runtime components for akonadi-kde
ii  libakonadi-kde4               4:4.4.4-1  library for using the Akonadi PIM 
ii  libc6                         2.11.1-2   Embedded GNU C Library: Shared lib
ii  libkdecore5                   4:4.4.4-1  the KDE Platform Core Library
ii  libkdepim4                    4:4.4.4-1  KDE PIM library
ii  libkdeui5                     4:4.4.4-1  the KDE Platform User Interface Li
ii  libkhtml5                     4:4.4.4-1  the KHTML Web Content Rendering En
ii  libkio5                       4:4.4.4-1  the Network-enabled File Managemen
ii  libkontactinterface4          4:4.4.4-1  Kontact interface library
ii  libkparts4                    4:4.4.4-1  the Framework for the KDE Platform
ii  libkpimidentities4            4:4.4.4-1  library for managing user identiti
ii  libkpimutils4                 4:4.4.4-1  library for dealing with email add
ii  libkutils4                    4:4.4.4-1  various utility classes for the KD
ii  libqt4-dbus                   4:4.6.2-5  Qt 4 D-Bus module
ii  libqtcore4                    4:4.6.2-5  Qt 4 core module
ii  libqtgui4                     4:4.6.2-5  Qt 4 GUI module
ii  libstdc++6                    4.4.4-4    The GNU Standard C++ Library v3

Versions of packages kontact recommends:
ii  akregator                     4:4.4.4-1  RSS/Atom feed aggregator for KDE
ii  kaddressbook                  4:4.4.4-1  KDE address book
ii  kmail                         4:4.4.4-1  KDE Email client
ii  knotes                        4:4.4.4-1  KDE sticky notes
ii  korganizer                    4:4.4.4-1  KDE personal organizer

Versions of packages kontact suggests:
pn  gnokii                        <none>     (no description available)
ii  kjots                         4:4.4.4-1  note-taking utility for KDE 4
ii  knode                         4:4.4.4-1  KDE news reader
pn  ktimeticker                   <none>     (no description available)

-- no debconf information

Reply to: