[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#386334: marked as done (ktalkd: inetd as nobody.tty causes setgid/setuid as myuser: Operation not permitted)

Your message dated Sun, 14 Mar 2010 18:02:08 -0400
with message-id <9f694b821003141502r606b6b23raff567b6cd687c@mail.gmail.com>
and subject line Closing bug # 206843
has caused the Debian Bug report #206843,
regarding ktalkd: inetd as nobody.tty causes setgid/setuid as myuser: Operation not permitted
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

206843: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=206843
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: ktalkd
Version: 4:3.5.4-2
Severity: normal

ktalkd is set to run as nobody.tty in /etc/inetd.conf.  When I try to
connect to it I get this in /var/log/daemon.log

Sep  6 16:03:24 pineapple ktalkd[6692]: connect from (
Sep  6 16:03:24 pineapple ktalkd[6692]: bad dns
Sep  6 16:03:25 pineapple ktalkd[6692]: bad dns
Sep  6 16:03:26 pineapple ktalkd[6693]: connect from (
Sep  6 16:03:26 pineapple ktalkd[6693]: XDM login: myuser at :0
Sep  6 16:03:26 pineapple ktalkd[6694]: Warning: setgid/setuid as myuser: Operation not permitted
Sep  6 16:03:26 pineapple ktalkd[6692]: bad dns

I think the "setgid/setuid as myuser: Operation not permitted" line is
the problem.  The same problem exists in Etch as well.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-1-686
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages ktalkd depends on:
ii  kdelibs4c2a                   4:3.5.4-2  core libraries and binaries for al
ii  libc6                         2.3.6-16   GNU C Library: Shared libraries
ii  libgcc1                       1:4.1.1-5  GCC support library
ii  libqt3-mt                     3:3.3.6-3  Qt GUI Library (Threaded runtime v
ii  libstdc++6                    4.1.1-5    The GNU Standard C++ Library v3
ii  netbase                       4.25       Basic TCP/IP networking system

Versions of packages ktalkd recommends:
ii  talk                          0.17-11    Chat with another user
pn  ytalk                         <none>     (no description available)

-- no debconf information

--- End Message ---
--- Begin Message ---
This bug won't be fix upstream (and has been closed). See comment at
"------- Comment #2 From David Faure 2008-07-03 19:08:35 (-) [reply] -------

So people are still using ktalkd? That's amazing.
It has been removed from KDE 4, for two reasons: apparent lack of
interest from users (IM has replaced talk for most people), and a
large number of security issues (I wrote ktalkd before I knew anything
about security, which is bad for a daemon running as root)....
Sorry, I don't think this bug will ever get fixed :("

--- End Message ---

Reply to: