[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libqca2-plugin-gnupg and license

Sune Vuorela wrote:
> On Thursday 09 July 2009 21:42:01 Adam Majer wrote:
>> For starters, the package libqca2-plugin-gnupg links with GnuPG. 
> No. libqca2-plugin-gnupg does not link with gnupg. GnuPG is a command line 
> tool and you can't link with those.
> There is libgpgme, that the plugin uses. libgpgme executes gpg on command line 
> and parses that output. That's not linking.
>> PS. I'm not on the list so CC me on replies.

Oh I see... So basically anyone can take any GPL library or utility,
make a cheap GPL wrapper on top of it (in case of library), then use the
wrapper in a closed source program. Performance will suffer, but I guess
for not critical sections it doesn't matter.

Seems like the Achilles heel of GPL. But that discussion doesn't belong


Reply to: