[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#490160: marked as done (libqt4-webkit / arora: SIGBUS on sparc)

Your message dated Fri, 11 Jul 2008 13:10:05 +0200
with message-id <20080711111004.GL17256@sym.noone.org>
and subject line Re: Bug#490160: libqt4-webkit / arora: SIGBUS on sparc
has caused the Debian Bug report #490160,
regarding libqt4-webkit / arora: SIGBUS on sparc
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

490160: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=490160
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libqt4-webkit
Version: 4.4.0-3
Severity: grave

The web browser arora (which uses QT's WebKit as rendering engine)
crashes with SIGBUS on Sparc with the default configuration (which
IIRC tries to load the Arora project home page).

This is very likely the same memory alignment problem as in the GTK
version of WebKit (as already predicted by GTK WebKit's maintainer),
see http://bugs.debian.org/487745 for details. This and the backtrace
below make me believe that this is not a bug in arora but in QT's

$ gdb arora
GNU gdb 6.7.1-debian
Copyright (C) 2007 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "sparc-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) r
Starting program: /usr/bin/arora 
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xf6532710 (LWP 14629)]

Program received signal SIGBUS, Bus error.
[Switching to Thread 0xf6532710 (LWP 14629)]
0xf7c3ce44 in WebCore::ValueList::addValue (this=0x174648, v=@0xffa546f8)
    at ../JavaScriptCore/wtf/Vector.h:635
635     ../JavaScriptCore/wtf/Vector.h: No such file or directory.
        in ../JavaScriptCore/wtf/Vector.h
Current language:  auto; currently c++
(gdb) bt
#0  0xf7c3ce44 in WebCore::ValueList::addValue (this=0x174648, v=@0xffa546f8)
    at ../JavaScriptCore/wtf/Vector.h:635
#1  0xf7c3c0e4 in cssyyparse (parser=0xffa55d90) at ../css/CSSGrammar.y:1022
#2  0xf76499b8 in WebCore::CSSParser::parseSheet (this=0xffa55d90, 
    sheet=0x16c550, string=@0xffa55ebc) at css/CSSParser.cpp:201
#3  0xf76799d0 in WebCore::CSSStyleSheet::parseString (this=0x16c550, 
    string=@0xffa55ebc, strict=true) at css/CSSStyleSheet.cpp:158
#4  0xf76607b0 in parseUASheet (
    characters=0xf7c98ef8 "namespace \"http://www.w3.org/1999/xhtml\";; html { display: block } head { display: none } meta { display: none } title { display: none } link { display: none } style { display: none } script { display:"..., 
    size=8078) at css/CSSStyleSelector.cpp:342
#5  0xf7660ea4 in WebCore::CSSStyleSelector::loadDefaultStyle ()
    at css/CSSStyleSelector.cpp:348
#6  0xf7672c7c in CSSStyleSelector (this=0x16c240, doc=0x16ab58, 
    userStyleSheet=@0x16ac14, styleSheets=0x16b2e0, _strictParsing=true)
    at css/CSSStyleSelector.cpp:230
#7  0xf7695ba8 in Document (this=0x16ab58, impl=<value optimized out>, 
    frame=0x15b000, isXHTML=false) at dom/Document.cpp:317
#8  0xf7782ce8 in HTMLDocument (this=0x16ab58, implementation=0x16a938, 
    frame=0x15b000) at html/HTMLDocument.cpp:82
#9  0xf76a8b18 in WebCore::DOMImplementation::createDocument (this=0x16a938, 
    type=@0x15b48c, frame=0x15b000, inViewSourceMode=<value optimized out>)
    at dom/DOMImplementation.cpp:361
#10 0xf77fb4a4 in WebCore::FrameLoader::begin (this=0x15b348, url=@0xffa56714, 
    dispatch=<value optimized out>) at loader/FrameLoader.cpp:894
#11 0xf78068b0 in WebCore::FrameLoader::init (this=0x15b348)
    at loader/FrameLoader.cpp:272
#12 0xf79c4e74 in QWebFrame (this=0x15ad30, parent=0x136098, 
    frameData=0xffa569d0) at ../WebKit/qt/Api/qwebframe.cpp:171
#13 0xf79cc2ac in QWebPagePrivate::createMainFrame (this=0x15a338)
    at ../WebKit/qt/Api/qwebpage.cpp:186
#14 0xf79cc308 in QWebPage::mainFrame (this=0x136098)
    at ../WebKit/qt/Api/qwebpage.cpp:987
#15 0xf79cc338 in QWebPage::setViewportSize (this=0x136098, size=@0xffa56bb0)
    at ../WebKit/qt/Api/qwebpage.cpp:1353
#16 0xf79cc7f4 in QWebPage::setView (this=0x136098, view=0x159f20)
    at ../WebKit/qt/Api/qwebpage.cpp:1017
#17 0xf79cc948 in QWebPage (this=0x136098, parent=0x159f20)
    at ../WebKit/qt/Api/qwebpage.cpp:961
#18 0x00077a54 in ?? ()
#19 0x00077bf8 in ?? ()
#20 0x0007204c in ?? ()
#21 0x00071a44 in ?? ()
#22 0x00042b00 in ?? ()
#23 0x00042d58 in ?? ()
#24 0x0003a6f8 in ?? ()
#25 0x0007ec44 in ?? ()
#26 0xf68dac5c in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#27 0xf68e1fa0 in ?? () from /usr/lib/libQtCore.so.4
#28 0xf68d5464 in QObject::event () from /usr/lib/libQtCore.so.4
#29 0xf6c21318 in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#30 0xf6c21450 in QApplication::notify () from /usr/lib/libQtGui.so.4
#31 0xf68c184c in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#32 0xf68f6610 in ?? () from /usr/lib/libQtCore.so.4
#33 0xf68f2a40 in ?? () from /usr/lib/libQtCore.so.4
#34 0xf61e8274 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#35 0xf61ec278 in ?? () from /usr/lib/libglib-2.0.so.0
#36 0xf61ec278 in ?? () from /usr/lib/libglib-2.0.so.0
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (600, 'unstable'), (400, 'stable'), (110, 'experimental')
Architecture: sparc (sparc64)

Kernel: Linux 2.6.24-1-sparc64
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libqt4-webkit depends on:
ii  libc6                         2.7-10     GNU C Library: Shared libraries
ii  libgcc1                       1:4.3.1-2  GCC support library
ii  libqt4-network                4.4.0-3    Qt 4 network module
ii  libqtcore4                    4.4.0-3    Qt 4 core module
ii  libqtgui4                     4.4.0-3    Qt 4 GUI module
ii  libsqlite3-0                  3.5.9-3    SQLite 3 shared library
ii  libstdc++6                    4.3.1-2    The GNU Standard C++ Library v3

libqt4-webkit recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Package: libqt4-webkit
Version: 4.4.0-4

On Thu, Jul 10, 2008 at 08:44:18PM +0200, Sune Vuorela wrote:
> To leave a "paper trail" in the bts, the patches of GTK webkit were
> ported and uploaded yesterday. but is not yet available on sparc,
> but is supposed to fix this.

Yeah, 4.4.0-4 works fine on Sparc. No more SIGBUS. Thanks!

		Regards, Axel
Axel Beckert - abe@deuxchevaux.org, abe@noone.org - http://noone.org/abe/

--- End Message ---

Reply to: