[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#385299: umbrello: Umbrello should depend on kdebase-bin

Package: umbrello
Version: 4:3.5.5-3
Followup-For: Bug #385299

retitle  #385299 Umbrello should depend on kdebase-bin 
severity #385299 serious
tag #385299 +patch



I have used umbrello in a GNOME environement and experience the same bug
as you. To resolved it I had to manually install kdebase-bin (which
contains the 'drkonqi' executable).

I have set the severity to serious according to
http://release.debian.org/etch_rc_policy.txt : 

> Packages must include a "Depends:" line listing any other packages they
> require for operation, unless those packages are marked "Essential: yes"


-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-powerpc
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)

Versions of packages umbrello depends on:
ii  kdelibs4c2a            4:3.5.5a.dfsg.1-6 core libraries and binaries for al
ii  libart-2.0-2           2.3.17-1          Library of functions for 2D graphi
ii  libaudio2              1.8-3             The Network Audio System (NAS). (s
ii  libc6                  2.3.6.ds1-11      GNU C Library: Shared libraries
ii  libfontconfig1         2.4.2-1           generic font configuration library
ii  libfreetype6           2.2.1-5           FreeType 2 font engine, shared lib
ii  libgcc1                1:4.1.1-21        GCC support library
ii  libice6                1:1.0.1-2         X11 Inter-Client Exchange library
ii  libidn11               0.6.5-1           GNU libidn library, implementation
ii  libjpeg62              6b-13             The Independent JPEG Group's JPEG 
ii  libpng12-0             1.2.15~beta5-1    PNG library - runtime
ii  libqt3-mt              3:3.3.7-3         Qt GUI Library (Threaded runtime v
ii  libsm6                 1:1.0.1-3         X11 Session Management library
ii  libstdc++6             4.1.1-21          The GNU Standard C++ Library v3
ii  libx11-6               2:1.0.3-5         X11 client-side library
ii  libxcursor1            1.1.7-4           X cursor management library
ii  libxext6               1:1.0.1-2         X11 miscellaneous extension librar
ii  libxft2               FreeType-based font drawing librar
ii  libxi6                 1:1.0.1-4         X11 Input extension library
ii  libxinerama1           1:1.0.1-4.1       X11 Xinerama extension library
ii  libxml2                2.6.27.dfsg-1     GNOME XML library
ii  libxrandr2             2:       X11 RandR extension library
ii  libxrender1            1:0.9.1-3         X Rendering Extension client libra
ii  libxslt1.1             1.1.19-1          XSLT processing library - runtime 
ii  libxt6                 1:1.0.2-2         X11 toolkit intrinsics library
ii  zlib1g                 1:1.2.3-13        compression library - runtime

umbrello recommends no packages.

-- no debconf information

Index: kdesdk-3.5.5/debian/changelog
--- kdesdk-3.5.5.orig/debian/changelog	2007-02-19 13:54:40.000000000 +0100
+++ kdesdk-3.5.5/debian/changelog	2007-02-19 13:55:19.000000000 +0100
@@ -1,3 +1,10 @@
+kdesdk (4:3.5.5-3.1) unstable; urgency=low
+  * Non-maintainer upload.
+  * Depends on kdebase-bin (Closes: #385299) 
+ -- Djoume SALVETTI <djoume@taket.org>  Mon, 19 Feb 2007 13:54:50 +0100
 kdesdk (4:3.5.5-3) unstable; urgency=low
   * Update automake 1.10 support patch as cdbs runs patch with -p1 before -p0
Index: kdesdk-3.5.5/debian/control
--- kdesdk-3.5.5.orig/debian/control	2007-02-19 13:54:21.000000000 +0100
+++ kdesdk-3.5.5/debian/control	2007-02-19 13:54:33.000000000 +0100
@@ -326,7 +326,7 @@
 Package: umbrello
 Architecture: any
 Section: devel
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, kdebase-bin
 Suggests: khelpcenter, kdesdk-doc-html
 Conflicts: umbrello-manual (<< 20040311)
 Replaces: umbrello-manual (<< 20040311)

Reply to: