[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#358459: Language negotiation problem

On Sat, Sep 02, 2006 at 01:59:13AM +0200, Sylvain Sauvage wrote:
> Samedi 2 septembre 2006, 00:49:51 CEST, Jens Seidel a écrit :
> > On Sat, Sep 02, 2006 at 12:08:56AM +0200, Sylvain Sauvage wrote:
> I know it worked with Firefox but as it didn't worked with Konqueror (and
> a message was posted on debian-user-french about problems with Epiphany),
> I meant with Konqueror:
> it, es -> Italian
> it, en -> English
> fr, en -> English
> es, fr -> French
> Why not always the last one, or the first one, or English?
> > > Sometimes I get the first listed language, sometimes English, or the
> > > last one...
> > > Maybe I'm wrong, but it seems www.debian.org does something wrong,
> > > doesn't it ?
> > 
> > Please a different server, such as www.de.debian.org. Can you still
> > reproduce it?
> With Konqueror yes. Firefox is OK.
> Setting Languages=fr-fr,fr;q=0.8,en-us;q=0.5,en;q=0.3 in kio_httprc
> solves the problem on www.{it,fr,jp,de,}.debian.org (and others, I
> guess ;o).

Yep, for me too. Does this mean the problem is fixed now for everyone
and every server? I will update
http://www.de.debian.org/intro/cn#konqueror to reflect this.

I still get English pages without a Languages= line at all. But I think
KDE should deliver the single default language in this case. Only if
multiple languages are requested ~/.kde/share/config/kio_httprc needs to
be modified!?

> Oh, about the bug report you pointed: the poster says he has only
> problems with w.de.d.o, not others. Aren't all sites exact mirrors?

The poster is me :-)

In the past I was able to reproduce it only with the German mirror,
later I noticed the problem also in other mirrors and now it vanished!?

I assumed it also depends on the web server which the Debian project
cannot dictate on mirrors.

Can other users please test konqueror?


Reply to: