[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: extragear/multimedia/kmplayer/debian

On Wed, Oct 19, 2005 at 11:28:12PM +0200, Adeodato Simó wrote:
> * Koos Vriezen [Wed, 19 Oct 2005 20:56:13 +0000]:
> Hi, Koos.


> > -Depends: kdelibs4 (>= 4:3.1.0-1), libxine1, libgstreamer0.8-0, libgstreamer-plugins0.8-0
> > +Depends: kdelibs4 (>= 4:3.1.0-1) | kdelibs4c2 (>= 4:3.4.0-1), libxine1 | libxine1c2, libgstreamer0.8-0, libgstreamer-plugins0.8-0
>   This should be done with the ${shlib:Depends} mechanism, really.

Well, I'm an absolute zero when it comes to this (or just too lazy to
really figure out what should have been done, though I did read the
tutorial which of course only handled the simple case where one source
package created one .dep package).

But anyways, you mean that the line above should be

  Depends: ${shlib:Depends}

and that magically works because of the build dependency is

  Build-Depends: debhelper (>= 4.0.0), kdelibs4-dev, libxine-dev, \
    xlibs-dev, libgstreamer0.8-dev, libgstreamer-plugins0.8-dev

Is that correct?



Reply to: