[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#639041: PTS mail interface doesn't have an up-to-date list of packages


On 23/08/2011 22:28, Raphael Hertzog wrote:
>> Maybe the list of packages isn't properly kept in sync somewhere?
> Indeed, the list that was used is no longer provide by the BTS and
> in commit r2518 I updated some other part of the code to work without
> that sources.map file. At that time I did not notice that the mail
> part of the PTS was still using it... cf $sources in perl/common.pl.
> So we have to reintroduce that file somehow (UDD export?) or adjust the mail
> part to get this information in some other way. Giovanni, do you feel like
> taking care of this problem ?

Actually I don't know nearly anything of Perl, so I doubt I can
contribute to that part. The binary <-> source mapping is actually
already available, it is computed by sources_to_xml.py and then pickled
and stored in www/base/sources_mapping. It should be easy to store it
(also) in a format that Perl can import (for example JSON). And it
should also be easy to instruct Perl to read such file, provided that
you know Perl.

> ---
> r2518 | hertzog | 2011-05-01 22:34:08 +0200 (dim. 01 mai 2011) | 8 lignes
> Stop relying on sources.map file that used to be provided by the BTS.
> Instead we compute our own map.
> [...]
> ---
>> The subscription process appears to work and mails to
>> fdsend@packages.qa.debian.org are properly forwarded, so this appears to
>> be a purely cosmetic issue.
> Yes, it's only cosmetic.

Well, it also means that you can't subscribe to a package by its binary
name. I tried to subscribe to subscribe to libmodbus5 (binary package
generated by libmodbus, accepted in unstable on August, 20th): the bot
replied with the wrong email as before, but also sent me the
confirmation token. But the confirmation token contained libmodbus5, not
libmodbus, as "source" package name, so it probably wouldn't be able to
subscribe me correctly if I answered. For double check, I also tried to
subscribe to geogebra-gnome (built by geogebra), which has been
available in unstable since about an year, and it correctly sent a token
with geogebra in it.

I'll try to have another look at it, but, as I said, I'm not a Perl hacker.

Giovanni Mascellani <mascellani@poisson.phc.unipi.it>
Pisa, Italy

Web: http://poisson.phc.unipi.it/~mascellani
Jabber: g.mascellani@jabber.org / giovanni@elabor.homelinux.org

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: