Re: UDD: proposed schema changes.
On Sun, Sep 21, 2008 at 09:21:40PM +0200, Lucas Nussbaum wrote:
> On 21/09/08 at 20:37 +0200, Kurt Roeckx wrote:
> > Hi,
> > I'd like to make some minor changes the current udd schema:
> > - Make severity an enum instead of text:
> > CREATE TYPE bugs_severity AS ENUM ('fixed', 'wishlist', 'minor', 'normal', 'important', 'serious', 'grave', 'critical');
> > This would allow to make queries using something like
> > severity >= 'serious', and get what you expect, instead of a string
> > compare.
> > - Add an affects_experimental in bugs and archived_bugs
> > - Rename affects_sarchived_table to affects_stable and
> > affects_unsarchived_table to affects_unstable in
> > archived_bugs.
> > Does anybody have any probems with those?
> No, please go ahead.
> | Lucas Nussbaum
> | email@example.com http://www.lucas-nussbaum.net/ |
> | jabber: firstname.lastname@example.org GPG: 1024D/023B3F4F |
> To UNSUBSCRIBE, email to debian-qa-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact email@example.com