[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#675488: sgml-data: please rebuild to fix your copy of #477751

Source: sgml-data
Severity: serious

Dear maintainer(s) of sgml-data,

TL;DR: Please upload a new version of this package closing this bug.

Your package uses the dh_installcatalogs helper from debhelper. This helper
added code to the postinst that unconditionally overwrites files in /etc which
is a policy violation. The corresponding bug #477751 is now solved in
debhelper. Nevertheless the code overwriting files in /etc is still present in
a binary package built from this source package, so your package needs a
rebuild. Unfortunately the binary package in question is Architecture: all, so
a binNMU is not enough.

How to solve
This bug tracks the progress of the rebuild and should be closed by any upload
of this package. Before building, please ensure that your debhelper version is
at least 9.20120528 which should be the case if you are running sid. 

Is my package really/still affected?
Any binary package using the dh_installcatalogs helper will add a versioned
dependency on sgml-base. If the depended upon version is at least 1.26+nmu2,
your package is not affected. In that case, just close this bug.

If you have any further questions concerning this issue, please don't hesitate
to contact me.

Thanks for your help


Reply to: