[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#606038: sgml-data: WARNING about obsolete update-catalog command

Package: sgml-data
Version: 2.0.5
Severity: normal

When installing/upgrading sgml-data:

  Unpacking replacement sgml-data ...

  Setting up sgml-data (2.0.5) ...

  WARNING: You are using the compatibility symlink `update-catalog'.
  WARNING: This command will disappear in the future (see #88008).
  WARNING: The command is now named `update-sgmlcatalog'.

  Use of uninitialized value $add in numeric eq (==) at /usr/sbin/update-catalog line 205.


This warning message repeats many times and the package is set up.

The postinst and prerm package scripts should be changed to use
'update-sgmlcatalog' instead of 'update-catalog' to avoid future breakage
when update-catalog is eventually removed.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages sgml-data depends on:
ii  sgml-base                     1.99.0     SGML infrastructure and SGML catal
ii  xml-core                      0.13       XML infrastructure and XML catalog

sgml-data recommends no packages.

Versions of packages sgml-data suggests:
pn  doc-html-w3                 <none>       (no description available)
ii  libxml2-utils               2.7.8.dfsg-1 XML utilities
ii  opensp                      1.5.2-8      OpenJade group's SGML parsing tool
pn  perlsgml                    <none>       (no description available)

-- no debconf information

Reply to: