[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#463598: /var/run/utmp exists, but wdm still doesn't register the session

On Fri, May 21, 2010 at 09:36:47PM +0300, Yury Bulka wrote:
> Hello! Let me firstly thank you for your work on this package and for reading this:)
> So here's what the report is about:
> I've also noticed that wdm doesn't register the session it starts to utmp, but in my case /var/run/utmp exists on my system.
> It's strange, because the "sessreg" command is in its place in file /etc/X11/wdm/Xstartup:
> ---
> # Insert a utmp entry for the session
> if grep -q ^use-sessreg /etc/X11/wdm/wdm.options; then
>   exec sessreg -a -l $DISPLAY -u /var/run/utmp -x /etc/X11/wdm/Xservers $USER
> fi
> ---
> and the option "use-sessreg" is enabled in /etc/X11/wdm/wdm.options.
> I tried to install xdm and it does register the session with almost identical "sessreg" command (the only difference is the -x parameter which is set to "/etc/X11/xdm/Xservers" there)...

I replaced wdm Xstartup with xdm Xstartup and s/xdm/wdm/g. No luck, it still
does not register session. I have verified that $DISPLAY and $USER values
just before the sessreg call are correct and so that the sessreg line is
processed if use-sessreg is enabled.

I am curious, did it register session at some time?

In the box where wdm is installed last time /var/log/wdm.log was updated was
long time ago, on November 2005 for sid. I wonder what happened at that time.
I think about something related to xfree86 -> xorg transition (last xfree86 
log in this sid box is from September 2005).

Thanks for your feedback,


Reply to: