[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241163: marked as done (positron: editpl crashes (Invalid record: ID bit not set))

Your message dated Fri,  5 Feb 2010 01:17:54 +0000 (WET)
with message-id <20100205011755.037D611058@kmos.homeip.net>
and subject line Package positron has been removed from Debian
has caused the Debian Bug report #241163,
regarding positron: editpl crashes (Invalid record: ID bit not set)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

241163: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=241163
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: positron
Version: 1:1.0-5
Severity: normal

I have two playlists on my Neuros which I've built up with multiple
"positron addtopl ..." commands.  Any attempt to edit one of them with
"positron editpl" results in a crash like the one shown here:

$ positron editpl Chill
Traceback (most recent call last):
  File "/usr/bin/positron", line 180, in ?
  File "/usr/bin/positron", line 162, in main
    cmd.run(config, myNeuros, remaining[1:])
  File "/usr/lib/python2.3/site-packages/positron/cmd_editpl.py", line 71, in run
    record = audio_db.mdb.read_record_at(ptr)[0]
  File "/usr/lib/python2.3/site-packages/positron/db/MDB.py", line 193, in read_record_at
    raise Error("Invalid record: ID bit not set")
positron.db.util.Error: Invalid record: ID bit not set

These playlists were actually created with the previous positron .deb,
not the current version.  I don't know whether that's relevant, but the
crash also occurred on the previous version.

Adding new files to the playlists works fine.  I just can't *read* them
to see what's already there.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.25
Locale: LANG=en_US.ISO8859-1, LC_CTYPE=en_US.ISO8859-1

Versions of packages positron depends on:
ii  python                        2.3.3-6    An interactive high-level object-o
ii  python-id3                    1.2-6.1    Python module for id3-tags manipul
ii  python-pyvorbis               1.3-1      A Python interface to the Ogg Vorb

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 1:1.1-2+rm

You filed the bug http://bugs.debian.org/241163 in Debian BTS
against the package positron. I'm closing it at *unstable*, but it will
remain open for older distributions.

For more information about this package's removal, read
http://bugs.debian.org/392672. That bug might give the reasons why
this package was removed and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

Marco Rodrigues

--- End Message ---

Reply to: