[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#549407: ivtools 1.2.6-1 FTBFS on sparc and powerpc

On Fri, Nov 06, 2009 at 01:07:51PM +0100, Agustin Martin wrote:
> That is, #549407 is still present in powerpc and sparc (retitling to note
> that). 
> In the meantime I have sucessfully built ivtools 1.2.6-1+nmu2 in smetana, a
> Debian sparc machine with no changes at all in the package. Just built fine
> out of the box (nmu1 also did). So #549407 is really confusing. Noting that
> smetana is a dual UltraSparc IIIi v210 while lebrun, the sparc autobuilder,
> is a Dual UltraSparc III 750Mhz.
> powerpc problem is exacly the same and did not appear for 1.2.6-1, only
> appeared after 1.2.6-1+nmu1. However, nothing related to that was changed in
> the nmu. The only change was that 1.2.6-1 was built in voltaire (a Dual G4
> PowerPC 500Mhz) while 1.2.6-1+nmu1 was built in praetorius (IBM p690 LPAR, 2
> x POWER4 1.3GHz). Everything else regarding compilation was exactly the
> same.
> I have looked a bit more at the build log and the supposedly missing files,
> and they are non-dangling symlinks shipped in upstream tarball, seem no
> missing at all. 
> So, I am extremely confused about this bug. All the above seems to point to
> a race condition, but I cannot find out where it happens.
> I can put more -j1 in package debian/rules and see what happens when
> uploading again, but I really dislike that. I also have the sparc debs built
> at smetana that could be uploaded. Did not try in a powerpc box.

Hmm, what is this? Looking in the build logs just before the breakage,

>From praetorius log,

depending for LINUX in
make[5]: Entering directory

>From lebrun log,

depending for LINUX in 
make[5]: Entering directory

They are different temporary directories. Are the sparc and powerpc autobuilders buggy here?

Cc'ing buildd tools developers mailing list, in case they can add some light
on this.



Reply to: