[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#425251: crafty IS using both cpu's when using smpmt=2

Package: crafty

This bug is not a bug but seems a misconfigutration.

This is easy to be reproduced:

unable to open book file [./book.bin].
book is disabled
unable to open book file [./books.bin].
hash table memory =   12M bytes.
pawn hash table memory =    2M bytes.
show book statistics
EGTB access enabled
using tbpath=./TB
0 piece tablebase files found
parallel threads disabled.

Crafty v20.14 (1 cpus)

White(1): mt=2
max threads set to 2
White(1): e4
              time used:  11.14
              time surplus   0.00  time limit 29.83 (+0.00) (3:28)
              depth   time  score   variation (1)
starting thread 1
                8     0.21   0.18   1. ... Nc6 2. Nc3 Nf6 3. Bb5 d5 4.
                                    Qf3 Bg4 5. Qf4 dxe4 6. Bxc6+ bxc6 7.
                                    Nxe4 Nxe4 8. Qxe4 (s=2
With top I see 100% CPU Utiölisation

I also tried the crafty 22.10 and it works fine...

This is what upstream Dr. Robert Hyatt wrote:


What exactly is the problem? The "parallel threads disabled"??? That's normal. 
If you add "smpnice=0" that will go away. All it means as that when Crafty is 
not "thinking" (ponder=off for example and it is the opponent's move) the 
threads are disabled so that they don't burn CPU. They will work just fine 
when it is actually searching

The program itself is not aware of the difference between cores and 
processors, that's up to the O/S. Crafty will run fine on multi-core boxes 
however, including 20.14... so long as you use the mt=2 or smpmt=2 (or 
whatever N is correct for the number of procesors/cores you want to use...

With the 20.14 you should be able to get 100% cpu with no problems, _unless_ 
the 20.14 version you have was compiled without SMP support. You can open a 
command prompt window, cd to the crafty directory and start crafty manually. 
Then type mt=2 and see if it complains. If so, it means the executable you 
have was not compiled with SMP support enabled...


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages crafty depends on:
ii  libc6                         2.7-16     GNU C Library: Shared libraries
ii  libstdc++6                    4.3.2-1    The GNU Standard C++ Library v3

Versions of packages crafty recommends:
pn  crafty-books-medtosmall | cra <none>     (no description available)
ii  xboard                        4.2.7-7.1  An X Window System Chess Board

crafty suggests no packages.

-- no debconf information

Reply to: