[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#514622: Re : Bug#514622 - Eboard/Crafty book.bin

Indeed it seems the issue comes from the crafty book.bin & book.bin packages. On the official ftp site (ftp://ftp.cis.uab.edu/pub/hyatt/) those files date back to 30/1/2007. At that time the latest stable version of crafty was 21.6, which is higher than the 20.17 version the error mesage complains about.

After further investigation i managed to get the book.bin & books.bin files provided on the ftp site to work.
book.bin & books.bin files provided by the crafty-books-medium debian package are dated from 04/03/2007. They should work according to that date, however crafty reports them as outdated.
So i replaced those files located in /var/lib/crafty by those from the ftp site. (Note : the book files on the ftp server are not that satisfying as they are much lighter that those provided from the crafty-book-xxx packages)

So to me the procedure to solve the issue seem to be :
--- Rebuild up-to-date crafty-books-medium, crafty-books-medtosmall and crafty-books-small packages. Either by asking the author to provide new book files or by creating new ones as explained here : http://www.cis.uab.edu/hyatt/craftydoc.html

--- En date de : Lun 9.2.09, Patrik Fimml <patrik@fimml.at> a écrit :
De: Patrik Fimml <patrik@fimml.at>
À: "shakaz" <shakaz2005@yahoo.fr>, 514622@bugs.debian.org, control@bugs.debian.org
Date: Lundi 9 Février 2009, 16h43

Subject: Re: Bug#514622: eboard: book.bin version outdated when using
crafty engine
In-Reply-To: <20090209151151.5632.47385.reportbug@localhost>
Pgp: S

retitle 514622 crafty reports book.bin as outdated
reassign 514622
crafty 22.10-1

On Mon, Feb 09, 2009 at 04:11:51PM +0100, shakaz wrote:
> When using the crafty engine in eboard, following error message appears :
> ERROR! book.bin not made by version 20.17 or later
> This results in the openings' book not being used, so the engine takes
> a lot more time to calculate moves at the opening of a game.

I cannot verify this as crafty is only available for i386, but eboard
does nothing more than passing the path of the book file to crafty, so I
guess this is an issue with the crafty package or the crafty book packages.

> Also of interest regarding the use of crafty in eboard :
> The book.bin & books.bin files are located in /var/lib/crafty/
> Eboard though looks for them in the following locations :
> ~/.eboard
> ~
> /usr/local/share/eboard
> /usr/share/eboard
> /usr/local/share/crafty

As of eboard-1.1.1-3, it will also search in /var/lib/crafty. (#161497)

Kind regards,

Ne pleurez pas si votre Webmail ferme. Récupérez votre historique sur Yahoo! Mail

Ne pleurez pas si votre Webmail ferme. Récupérez votre historique sur Yahoo! Mail
Reply to: