[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#355164: marked as done (ilisp: ilisp.el defaults to guile1.4 for the guile interpreter)

Your message dated Thu, 29 May 2008 16:49:10 +0100
with message-id <200805291549.m4TFnAlN011747@kmos.homeip.net>
and subject line ilisp has been removed from Debian, closing #355164
has caused the Debian Bug report #355164,
regarding ilisp: ilisp.el defaults to guile1.4 for the guile interpreter
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

355164: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355164
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: ilisp
Version: 5.12.0+cvs.2004.12.26
Severity: minor

I have only guile 1.6 and not guile 1.4 installed and whenever I start
a guile process in emacs using ilisp I get the error that
/usr/bin/guile1.4 does not exist.  It seems to be because the
following line (line 80) in /etc/ilisp/ilisp.el uses 1.4 for the guile
interpreter when it sets ilisp-site-hook:

	 (setq guile-program "/usr/bin/guile1.4")

If I set it to /usr/bin/guile it will start guile 1.6 for me without
an error.  It seems to me that with guile 1.8 having been just
released and the programs I know about (gnucash, gnotime) that use
guile using 1.6 rather than 1.4 now, it would be better to default
this to 1.6, or whatever /usr/bin/guile is, and let users override it
if they have a need for 1.4 or a different version.  Ideally, there
would be an emacs customization for setting which interpreter to use
for each lisp dialect.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14-2-powerpc
Locale: LANG=en_CA, LC_CTYPE=en_CA (charmap=ISO-8859-1)

Versions of packages ilisp depends on:
ii  common-lisp-controller        4.27       This is a Common Lisp source and c
ii  debconf [debconf-2.0]         1.4.71     Debian configuration management sy
ii  emacsen-common                1.4.17     Common facilities for all emacsen

Versions of packages ilisp recommends:
ii  ilisp-doc          5.12.0+cvs.2004.12.26 Documentation for ILISP package

-- debconf information:
* ilisp/fsf-compliant: false

--- End Message ---
--- Begin Message ---
Version: 5.12.0+cvs.2004.12.26+rm

The ilisp package has been removed from Debian testing, unstable and
experimental, so I am now closing the bugs that were still opened
against it.

For more information about this package's removal, read
http://bugs.debian.org/284376 . That bug might give the reasons why
this package was removed, and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

Marco Rodrigues

--- End Message ---

Reply to: