[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#480320: curlftpfs: Segfault mounting Kerberos server

Package: curlftpfs
Version: 0.9.1-3+b2
Severity: grave

It's not clear whether curlftpfs's option -o krb4 is intended to match
curl's --krb flag (which is both kerberos 4 and 5), but curlftpfs
simply crashes with a segmentation fault when I try to mount a
directory from a Kerberos 5 server:

 curlftpfs -d -o ftpfs_debug=2  -o krb4=clear ftp://user@server/ ~/fsa
 Segmentation fault

I cannot provide any useful stack trace information as debugging
symbols have been removed; I have tried to recompile with them present
but I was not successful.

(Note also bug in curl #480044 must be patched if this is to work;
I have patched this locally and can use curl directly to access
this server.)


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.22-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages curlftpfs depends on:
ii  fuse-utils             2.7.3-4           Filesystem in USErspace (utilities
ii  libc6                  2.7-10            GNU C Library: Shared libraries
ii  libcomerr2             1.40.8-2          common error description library
ii  libcurl3-gnutls        7.17.1-1          Multi-protocol file transfer libra
ii  libfuse2               2.7.3-4           Filesystem in USErspace library
ii  libgcrypt11            1.4.1-1           LGPL Crypto library - runtime libr
ii  libglib2.0-0           2.16.3-2          The GLib library of C routines
ii  libgnutls26            2.2.3~rc-1        the GNU TLS library - runtime libr
ii  libgpg-error0          1.4-2             library for common error values an
ii  libidn11               1.8-1             GNU libidn library, implementation
ii  libkrb53               1.6.dfsg.3-1      MIT Kerberos runtime libraries
ii  libldap-2.4-2          2.4.7-6.2         OpenLDAP libraries
ii  libtasn1-3             1.4-1             Manage ASN.1 structures (runtime)
ii  zlib1g                 1: compression library - runtime

curlftpfs recommends no packages.

-- no debconf information

Reply to: