[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#465945: directfb: FTBFS on GNU/kFreeBSD (due to unsatisfied Build-Depends on libts-dev)

Package: directfb
Severity: important
Version: 1.0.1-7
Tags: patch
User: glibc-bsd-devel@lists.alioth.debian.org
Usertags: kfreebsd


the current version has unsatisfied Build-Depends on libts-dev under non-linux ports.

Please, could you exclude linux specific package in Build-Depends
by using "libts-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386]".

Thanks for your cooperation.


--- debian/control~     2008-02-15 17:53:54.000000000 +0100
+++ debian/control      2008-02-15 17:53:54.000000000 +0100
@@ -6,8 +6,9 @@
 Vcs-Svn: svn://svn.debian.org/pkg-directfb/directfb/trunk/
 Homepage: http://www.directfb.org/
 Build-Depends: debhelper (>= 5.0.22), quilt (>= 0.40), autoconf, automake,
- libtool, pkg-config, libfreetype6-dev, libjpeg62-dev, libpng12-dev, libts-dev,
+ libtool, pkg-config, libfreetype6-dev, libjpeg62-dev, libpng12-dev,
  libmpeg3-dev, zlib1g-dev, x11proto-core-dev, libx11-dev, libxext-dev,
+ libts-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386],
  libsysfs-dev [alpha amd64 arm armel hppa i386 ia64 m68k mips mipsel powerpc ppc64 s390]
 Standards-Version: 3.7.3

Reply to: