[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#460182: ud: Upgrading 0.7.1-20 to 0.7.1-21 fails

Package: ud
Version: 0.7.1-20
Severity: important


An upgraded ud came down the pipe, but the upgrade fails. dselect transcript:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0B/26.3kB of archives.
After unpacking 4096B disk space will be freed.
Do you want to continue [Y/n]? 
Reading changelogs...
apt-listchanges: Mailing root: apt-listchanges: changelogs for reidster
(Reading database ... 113003 files and directories currently installed.)
Preparing to replace ud 0.7.1-20 (using .../archives/ud_0.7.1-21_i386.deb) ...
Stopping uptime daemon: udinvoke-rc.d: initscript ud, action "stop" failed.
dpkg: warning - old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
Stopping uptime daemon: udinvoke-rc.d: initscript ud, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/ud_0.7.1-21_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
Starting uptime daemon: ud.

Now configure ud, using /usr/sbin/udconfig

Errors were encountered while processing:
[ Rootkit Hunter version 1.3.0 ]
File updated: searched for 152 files, found 124
E: Sub-process /usr/bin/dpkg returned an error code (1)
Some errors occurred while unpacking. I'm going to configure the
packages that were installed. This may result in duplicate errors
or errors caused by missing dependencies. This is OK, only the errors
above this message are important. Please fix them and run [I]nstall again
Press enter to continue.

Also, the following appears in the syslog:

Jan 10 23:30:18 reidster ud[8936]: Uptime daemon starting...
Jan 10 23:30:18 reidster ud[8936]: Can't open stats file

Please let me know what questions I can answer to help resolve this. I'm also
happy to test potential fixes.



-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-2-k7 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Versions of packages ud depends on:
ii  debianutils                   2.28.2     Miscellaneous utilities specific t
ii  libc6                         2.7-5      GNU C Library: Shared libraries

ud recommends no packages.

-- no debconf information

Reply to: