[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#441353: tramp: please mention emacs22 includes tramp



On September 9, 2007 at 10:13AM +0200,
rfrancoise (at debian.org) wrote:

> Tatsuya Kinoshita <tats@vega.ocn.ne.jp> writes:
>
> > The tramp package depends on `emacs21 | xemacs21', because emacs22
> > itself includes tramp.  Please mention it in Description.
>
> Good idea.

Thank you.

> > Also, if emacs21 is removed from testing/unstable,
> > installing/upgrading tramp requires xemacs21 even if emacs22 is
> > installed.  I think that `Depends: emacs | emacsen' is better for
> > transition from emacs21 to emacs22 to avoid installing xemacs21.
>
> I don't agree, removing emacs21 from the archive will not remove it
> from the users' systems so upgrading tramp will not suddenly install
> xemacs21.  And forcing users to install emacs21 | xemacs21 alongside
> tramp on new installs is good, it will prompt emacs22 users to
> double-check if they really need it.

OK, I don't forcely recommend `emacs | emacsen'.

Could you please agree `xemacs21 | emacs21' instead of
`emacs21 | xemacs21' to prefer xemacs21 over emacs21?

--
Tatsuya Kinoshita

Attachment: pgp8UZDIu8PIU.pgp
Description: PGP signature


Reply to: