[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419301: Switch to dh_gtkmodules for the gtk 2.10 transition

Package: gtk2-engines-wonderland
Version: 1.0-3
Severity: serious
Usertags: gtk-2.10-transition


 I've uploaded Gtk 2.10 to unstable and it changes ABI, which means that
 your package will not work with Gtk 2.10 as is.  The Gtk 2.10 package
 added conflicts with the above version of your package to prevent any
 problem, but you need to update your package to call the new
 dh_gtkmodules tool: this tool will add a virtual dependency on the gtk
 ABI via ${misc:Depends} to make the next transition easier -- only an
 automatic rebuild will be needed for the next transition.

 Updating your package should be relatively easy:

 1) Bump up the libgtk2.0-dev build-dep to >= 2.10.1-1.

 2) Call dh_gtkmodules on the package(s) shipping the module(s).
      If you build a library in the same source, you might need to set
      an appropriate LD_LIBRARY_PATH for dh_gtkmodules to work.

 3) Make sure you have ${misc:Depends} in the dependencies of the
    package(s) shipping the module(s); this should add a
    gtk2.0-binver-2.10.0 dependency.

 4) If your package ships "gdk-pixbuf loaders" modules or "input
    methods" modules:
    a) Make sure you ship the new /usr/lib/gtk-2.0/*/loader-files.d/*
       and/or /usr/lib/gtk-2.0/*/immodule-files.d/* lists.
    b) Remove any call to update-gdkpixbuf-loaders or
       update-gtk-immodules or anything touching files in /etc/gtk-2.0
       in your postinst/postrm/etc. scripts.

 Please ask me if anything above isn't clear!

 A concrete example of all the above changes (worst case) is libwmf;
 this is how the necessary changes look like:

Loïc Minier

Reply to: