[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419301: marked as done (Switch to dh_gtkmodules for the gtk 2.10 transition)

Your message dated Sat, 14 Apr 2007 22:02:02 +0000
with message-id <E1HcqJm-0006IB-RX@ries.debian.org>
and subject line Bug#419301: fixed in gtk2-engines-wonderland 1.0-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: gtk2-engines-wonderland
Version: 1.0-3
Severity: serious
Usertags: gtk-2.10-transition


 I've uploaded Gtk 2.10 to unstable and it changes ABI, which means that
 your package will not work with Gtk 2.10 as is.  The Gtk 2.10 package
 added conflicts with the above version of your package to prevent any
 problem, but you need to update your package to call the new
 dh_gtkmodules tool: this tool will add a virtual dependency on the gtk
 ABI via ${misc:Depends} to make the next transition easier -- only an
 automatic rebuild will be needed for the next transition.

 Updating your package should be relatively easy:

 1) Bump up the libgtk2.0-dev build-dep to >= 2.10.1-1.

 2) Call dh_gtkmodules on the package(s) shipping the module(s).
      If you build a library in the same source, you might need to set
      an appropriate LD_LIBRARY_PATH for dh_gtkmodules to work.

 3) Make sure you have ${misc:Depends} in the dependencies of the
    package(s) shipping the module(s); this should add a
    gtk2.0-binver-2.10.0 dependency.

 4) If your package ships "gdk-pixbuf loaders" modules or "input
    methods" modules:
    a) Make sure you ship the new /usr/lib/gtk-2.0/*/loader-files.d/*
       and/or /usr/lib/gtk-2.0/*/immodule-files.d/* lists.
    b) Remove any call to update-gdkpixbuf-loaders or
       update-gtk-immodules or anything touching files in /etc/gtk-2.0
       in your postinst/postrm/etc. scripts.

 Please ask me if anything above isn't clear!

 A concrete example of all the above changes (worst case) is libwmf;
 this is how the necessary changes look like:

Loïc Minier

--- End Message ---
--- Begin Message ---
Source: gtk2-engines-wonderland
Source-Version: 1.0-4

We believe that the bug you reported is fixed in the latest version of
gtk2-engines-wonderland, which is due to be installed in the Debian FTP archive:

  to pool/main/g/gtk2-engines-wonderland/gtk2-engines-wonderland_1.0-4.diff.gz
  to pool/main/g/gtk2-engines-wonderland/gtk2-engines-wonderland_1.0-4.dsc
  to pool/main/g/gtk2-engines-wonderland/gtk2-engines-wonderland_1.0-4_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 419301@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matej Vela <vela@debian.org> (supplier of updated gtk2-engines-wonderland package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 14 Apr 2007 23:39:55 +0200
Source: gtk2-engines-wonderland
Binary: gtk2-engines-wonderland
Architecture: source i386
Version: 1.0-4
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matej Vela <vela@debian.org>
 gtk2-engines-wonderland - Wonderland theme for GTK+ 2.0
Closes: 419301
 gtk2-engines-wonderland (1.0-4) unstable; urgency=low
   * QA upload.
   * Switch to dh_gtkmodules for gtk 2.10.  Closes: #419301.
   * debian/rules: Let dh_strip handle DEB_BUILD_OPTIONS=nostrip.
   * Conforms to Standards version 3.7.2.
 76a804768bff9ca31e2ea5307ffeeb65 656 x11 optional gtk2-engines-wonderland_1.0-4.dsc
 0d469df7cbe6dd2141245c4e826e351a 21657 x11 optional gtk2-engines-wonderland_1.0-4.diff.gz
 351fc6f85ff347d201dfa3400b404bff 28172 x11 optional gtk2-engines-wonderland_1.0-4_i386.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: