[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#414094: dbengine unmaintained and buggy

Package: dbengine
Version: 1.1-17
Severity: serious

I am the former maintainer of this package.  I want it removed from 
Debian because it is seriously buggy under the versions of MySQL and 
PostgreSQL in this release, and it is unmaintained upstream.  I don't 
think is is worth fixing the upstream bugs in the Debian package because 
there are now much better Web interfaces to MySQL and PostgreSQL than 
dbengine ever was.

Some details of the bugs:

(a) Under MySQL, any operation on a database returns "Software error:
    Can't call method "disconnect" on unblessed reference at 
    /usr/lib/cgi-bin/dbengine.cgi line 265."

(b) Under PostgreSQL, the error is something like "Software error:
    ERROR:Action failed on command:SELECT a.attname, t.typname, ... 
    (0 rows found)  Error_was: at ./util/base.pl line 1480

I don't know what versions of MySQL and PostgreSQL these appeared with, 
because nobody reported any bugs before, but that probably just 
indicates that dbengine was not being used. 

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.4.26-3um
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages dbengine depends on:
ii  debconf [debconf-2.0]         1.5.8      Debian configuration management sy
ii  libdbd-mysql-perl             3.0008-1   A Perl5 database interface to the 
ii  libdbd-pg-perl                1.49-2     a PostgreSQL interface for Perl 5 
ii  libdbi-perl                   1.53-1     Perl5 database interface by Tim Bu
ii  perl [perl5]                  5.8.8-7    Larry Wall's Practical Extraction 

dbengine recommends no packages.

-- debconf information excluded

Reply to: