[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#390072: marked as done (aptitude reports libgtk-pixbuf-perl as broken and can't be upgraded)

Your message dated Sun, 19 Nov 2006 19:47:45 +0100
with message-id <1163962065.4033.281.camel@localhost>
and subject line libgtk-perl: aptitude reports libgtk-pixbuf-perl as broken and can't be upgraded
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libgtk-pixbuf-perl
Version: 0.7009-2
Severity: normal

When trying to dist-upgrade aptitude tries to upgrade libgtk-perl and libgtk-pixbuf-perl, the *pixbuf* won't install because it has unresolved dependencies against libgtk-perl.

By downgrading:

root@zond:~# aptitude dist-upgrade
The following packages have unmet dependencies:
  libgtk-pixbuf-perl: Depends: libgtk-perl (= 0.7009-6) but 0.7009-11 is to be installed.
Resolving dependencies...    
The following actions will resolve these dependencies:
Downgrade the following packages:
libgtk-perl [0.7009-6 (now) -> 0.7009-2 (stable)]
libgtk-pixbuf-perl [0.7009-6 (now) -> 0.7009-2 (stable)]
Score is -130                
Accept this solution? [Y/n/q/?] Y
The following packages will be DOWNGRADED:
  libgtk-perl libgtk-pixbuf-perl
0 packages upgraded, 0 newly installed, 2 downgraded, 0 to remove and 0 not upgraded.
Need to get 856kB of archives. After unpacking 24.6kB will be used.
Do you want to continue? [Y/n/?]
Unpacking replacement libgtk-perl ...
Setting up libgtk-perl (0.7009-2) ...
Setting up libgtk-pixbuf-perl (0.7009-2) ..

.... this doesn't help a bit, a dist-upgrad just after the downgrade makes aptitude propose to remove the packages.

maybe the bug should be filed against dvdrip, that seems to be the only app. affected in my system at least.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-1-k7
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages libgtk-pixbuf-perl depends on:
ii  libc6                     2.3.6.ds1-4    GNU C Library: Shared libraries
ii  libgdk-pixbuf2            0.22.0-11      The GdkPixBuf image library, gtk+ 
ii  libglib1.2                1.2.10-10.1    The GLib library of C routines
ii  libgtk-perl               0.7009-2       Perl module for the gtk+ library
ii  libgtk1.2                 1.2.10-18      The GIMP Toolkit set of widgets fo
ii  libx11-6                  2:1.0.0-9      X11 client-side library
ii  libxext6                  1:1.0.1-2      X11 miscellaneous extension librar
ii  libxi6                    1:1.0.1-3      X11 Input extension library
ii  perl                      5.8.8-6.1      Larry Wall's Practical Extraction 
ii  perl-base [perlapi-5.8.4] 5.8.8-6.1      The Pathologically Eclectic Rubbis
ii  xlibs                     6.9.0.dfsg.1-6 X Window System client libraries m

libgtk-pixbuf-perl recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
The submitter confirmed that "the issue is resolved".

Attachment: signature.asc
Description: This is a digitally signed message part

--- End Message ---

Reply to: