[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#362292: jython: FTBFS: Obsolete Build-Depends on python2.1



    Hi Ben,

 I have started to think about how to fix this jython RC bug.

 I don't think waiting for a new release of jython is a solution if we
want to have it in etch. So I'm considering shipping duplicates of python
2.1 modules.

 This raises some questions :
   1. which version of python 2.1 modules to include
   2. how to package these modules
   3. the support of /usr/lib/python2.1/site-packages

1. There are two possibilities : either take the modules from the jython
upstream binary release, which should be the same as the python upstream
version modulo the jython specific modules, or take the Debian python2.1
package (same modulo). Matthias Klose had patched some of the upstream
modules for his Debian package.

   Do you have preference/clue on this choice ?

2. Adding all these modules to the Debian diff is certainly not a
solution (it would be too big , no ?). That made me wonder how you
produced the jython tar.gz. On Jython website I only found a .class
release, nothing that looks like a source release. Did you reworked this
.class file ? Or worked from CVS ?

   I see to possibilities : either include the new modules in the tar.gz
or create a new source package (e.g. python2.1-modules) that would just
include these modules and which jython would build-depend on.

3. In your orphaning mail you mentioned the problem of the
/usr/lib/python2.1/site-packages. Wouldn't just keeping this directory
in the sys.path of jython suffices ? Modules droped in this directory
would still be available from jython.

  Thanks in advance for your help.
  Regards,

-- 
Nicolas Duboc <nduboc@debian.org>

Attachment: pgpULqIaLbs0F.pgp
Description: PGP signature


Reply to: