[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#260872: marked as done (python-gnome: FTBFS on amd64.)



Your message dated Fri, 7 Oct 2005 19:04:18 +0200
with message-id <20051007170418.GC8135@roeckx.be>
and subject line Bug#260872: python-gnome: FTBFS on amd64.
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 22 Jul 2004 16:59:15 +0000
>From Q@ping.be Thu Jul 22 09:59:15 2004
Return-path: <Q@ping.be>
Received: from adicia.telenet-ops.be [195.130.132.56] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BnguZ-0002xb-00; Thu, 22 Jul 2004 09:59:15 -0700
Received: from localhost (localhost.localdomain [127.0.0.1])
	by adicia.telenet-ops.be (Postfix) with SMTP id BB1124418D
	for <submit@bugs.debian.org>; Thu, 22 Jul 2004 18:59:13 +0200 (MEST)
Received: from kabel.telenet.be (D5E08CEF.kabel.telenet.be [213.224.140.239])
	by adicia.telenet-ops.be (Postfix) with ESMTP id AB3CA440A9
	for <submit@bugs.debian.org>; Thu, 22 Jul 2004 18:59:13 +0200 (MEST)
Received: by kabel.telenet.be (Postfix, from userid 501)
	id 1A2D915EAF4; Thu, 22 Jul 2004 18:59:13 +0200 (CEST)
Date: Thu, 22 Jul 2004 18:59:12 +0200
From: Kurt Roeckx <Q@ping.be>
To: submit@bugs.debian.org
Subject: python-gnome: FTBFS on amd64.
Message-ID: <20040722165912.GA7271@ping.be>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.4.2.1i
Sender: Q@ping.be
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 

Package: python-gnome
Version: 1.4.5-1
Severity: important

The package fails to build on amd64 with:
/bin/sh ../libtool --mode=link gcc  -g -O2   -o _gtkhtmlmodule.la -rpath
/usr/lib/python2.3/site-packages/gtk-1.2 -module -avoid-version
-export-symbols-regex init_gtkhtml gtkhtmlmodule.lo -rdynamic -L/usr/lib
-L/usr/X11R6/lib -lgtkhtml -lgal -lgnomeprint -lfreetype -lglade-gnome -lglade
-lxml -lz -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule
-ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb-3
-lglib -lgdk_pixbuf -lgnomecanvaspixbuf -L/usr/lib -lgconf-1 -loaf
-lORBitCosNaming -lORBit -lIIOP -lORBitutil -lglib -lm
grep: /usr/lib/libdb-4.2.la: No such file or directory
/bin/sed: can't read /usr/lib/libdb-4.2.la: No such file or directory
libtool: link: `/usr/lib/libdb-4.2.la' is not a valid libtool archive
make[4]: *** [_gtkhtmlmodule.la] Error 1
make[4]: Leaving directory `/usr/src/python-gnome-1.4.5/pygnome'


/usr/lib/libdb-4.2.la is provided by the libdb4.2-dev
package but that's not installed.  The libdb3-dev package
is installed because libgnome-dev depends on it.  It's
also linking to db-3.

I don't understand why it's trying to use that
libdb-4.2.la while it should be using the other version.
It worked without problems with the previous version.

The other .la files in the dir seem to be using
/usr/lib/libdb3.la as expected.

Somehow the previous version got build without problems.
Building the old version now also fails.  And trying the
same on i386 works.  I don't understand it at all.


Kurt


---------------------------------------
Received: (at 260872-done) by bugs.debian.org; 7 Oct 2005 17:04:20 +0000
>From kurt@roeckx.be Fri Oct 07 10:04:20 2005
Return-path: <kurt@roeckx.be>
Received: from adicia.telenet-ops.be [195.130.132.56] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1ENvds-00087N-00; Fri, 07 Oct 2005 10:04:20 -0700
Received: from localhost (localhost.localdomain [127.0.0.1])
	by adicia.telenet-ops.be (Postfix) with SMTP
	id 3F3F43818A; Fri,  7 Oct 2005 19:04:19 +0200 (CEST)
Received: from Q.roeckx.be (dD5775F4A.access.telenet.be [213.119.95.74])
	by adicia.telenet-ops.be (Postfix) with ESMTP
	id E78B138110; Fri,  7 Oct 2005 19:04:18 +0200 (CEST)
Received: by Q.roeckx.be (Postfix, from userid 501)
	id 8572426136; Fri, 07 Oct 2005 19:04:18 +0200 (CEST)
Date: Fri, 7 Oct 2005 19:04:18 +0200
From: Kurt Roeckx <kurt@roeckx.be>
To: Matej Vela <vela@debian.org>
Cc: 260872-done@bugs.debian.org
Subject: Re: Bug#260872: python-gnome: FTBFS on amd64.
Message-ID: <20051007170418.GC8135@roeckx.be>
References: <20040722165912.GA7271@ping.be> <87zmpmxf5m.fsf@diziet.irb.hr>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <87zmpmxf5m.fsf@diziet.irb.hr>
User-Agent: Mutt/1.4.2.1i
Delivered-To: 260872-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level: 
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

On Fri, Oct 07, 2005 at 03:57:25AM +0200, Matej Vela wrote:
> Kurt Roeckx <Q@ping.be> writes:
> 
> > grep: /usr/lib/libdb-4.2.la: No such file or directory
> > /bin/sed: can't read /usr/lib/libdb-4.2.la: No such file or directory
[...]
> 
> Neither do I, but 1.4.5-2.1 seems to have built correctly.  Can we
> close this?

Yes, this probably was a bug in some other package that was
missing a dependency.  I'm closing the bug.


Kurt



Reply to: