[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#299939: gkdial: Double-click on "Disconnect" causes a crash

Package: gkdial
Version: 1:1.8.0-3
Severity: grave
Tags: patch
Justification: causes non-serious data loss

Hash: SHA1

After the connection, when there is the window with 
connection statistics, duoble-click on the "Disconnect" 
button causes a crash...
Also, if gkdial was started inside of gnome, it causes the
silently close of every other windows opened (in all workspaces).

Digging in the source, I noted a comment for a piece of code 
re-used from modemligth gnome-applet. So I think this is the 
same bug as in Debian Bug #220796 and Gnome Bug #135464.

I have not attached more infos because it is marked solved in 
gnome 2.10, and probably the same updated code should be used as 
patch also for gkdial.

Ciao, Luca

- -- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.9
Locale: LANG=it_IT, LC_CTYPE=it_IT (charmap=ISO-8859-1)

Versions of packages gkdial depends on:
ii  libart-2.0-2            2.3.17-1         Library of functions for 2D graphi
ii  libatk1.0-0             1.8.0-4          The ATK accessibility toolkit
ii  libbonobo2-0            2.8.1-2          Bonobo CORBA interfaces library
ii  libbonoboui2-0          2.8.1-1          The Bonobo UI library
ii  libc6                   2.3.2.ds1-20     GNU C Library: Shared libraries an
ii  libgconf2-4             2.8.1-4          GNOME configuration database syste
ii  libglade2-0             1:2.4.2-1        library to load .glade files at ru
ii  libglib2.0-0            2.6.2-1          The GLib library of C routines
ii  libgnome2-0             2.8.0-6          The GNOME 2 library - runtime file
ii  libgnomecanvas2-0       2.8.0-1          A powerful object-oriented display
ii  libgnomeui-0            2.8.0-3          The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0          2.8.3-11         The GNOME virtual file-system libr
ii  libgtk2.0-0             2.6.2-3          The GTK+ graphical user interface 
ii  libice6                 4.3.0.dfsg.1-10  Inter-Client Exchange library
ii  liborbit2               1:2.10.5-0.1     libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0           1.8.0-3          Layout and rendering of internatio
ii  libpopt0                1.7-5            lib for parsing cmdline parameters
ii  libsm6                  4.3.0.dfsg.1-10  X Window System Session Management
ii  libx11-6                4.3.0.dfsg.1-10  X Window System protocol client li
ii  libxml2                 2.6.16-3         GNOME XML library
ii  ppp                     2.4.2+20040428-6 Point-to-Point Protocol (PPP) daem
ii  xlibs                   4.3.0.dfsg.1-11  X Keyboard Extension (XKB) configu
ii  zlib1g                  1:1.2.2-4        compression library - runtime

- -- no debconf information

Version: GnuPG v1.4.0 (GNU/Linux)


Reply to: