[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#227249: elm-me+: crashes on some pgp-signed mails

Package: elm-me+
Version: 2.4pl25ME+100-2
Severity: normal

On some PGP-signed E-Mails, elm crashes when trying to display them.
Here's a screenshot:

      Mailbox is '/var/mail/ig25' with 43 messages [ELM 2.4ME+ PL100 (25)]

     34  Jan 3  Dominique Devriese (59)   Re: Bug#196496: the KDE crash bug you
     35  Jan 3  Mail Delivery Syst (112)  Zustellung fehlgeschlagen: Mail zuruec
   U 36  Sep 18 Matt Zimmerman     (220)  [SECURITY] [DSA-387-1] New gopher pack
   U 37  Sep 18 Matt Zimmerman     (156)  [SECURITY] [DSA-386-1] New libmailtool
   U 38  Sep 18 Matt Zimmerman     (204)  [SECURITY] [DSA-385-1] New hztty packa
     39  Sep 18 root               (25)   Debconf: Configuring Ssh -- NOTE: Forw
   U 40  Sep 17 Wichert Akkerman   (178)  [SECURITY] [DSA-383-1] OpenSSH buffer
   U 41  Sep 17 Wichert Akkerman   (208)  [SECURITY] [DSA-382-2] OpenSSH buffer
   U 42  Sep 16 Wichert Akkerman   (217)  [SECURITY] [DSA-382-1] OpenSSH buffer
  OU 43  Sep 12 Matt Zimmerman     (1120) [SECURITY] [DSA-380-1] New xfree86 pa

When I try to display message number 43, I get the message

Running pgp: Checking signature...

and then nothing.  Typing ^C yields (nothing else seems to work)

gpg: Error writing to `-': Broken pipe
gpg: handle plaintext failed: file write error
gpg: no valid OpenPGP data found.
gpg: block_filter: error reading length info
gpg: block_filter: pending bytes!

and a return to the shell prompt, with /tmp/mbox.ig25 existing
(which means that I have to remove it before restarting elm).

$ grep -v '#' elmrc | grep -v '^$'
mimebodykeywords = OFF
userlevel = expert

$ dpkg --status gnupg
Package: gnupg
Status: install ok installed
Priority: standard
Section: utils
Installed-Size: 4324
Maintainer: James Troup <james@nocrew.org>
Version: 1.2.4-1


The Debian developers keyring isn't installed here.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux meiner 2.4.22-1-k7 #5 Sat Oct 4 14:11:12 EST 2003 i686
Locale: LANG=C, LC_CTYPE=de_DE@euro

Versions of packages elm-me+ depends on:
ii  exim [mail-transport-agen 3.36-9.1       An MTA (Mail Transport Agent)
ii  libc6                     2.3.2.ds1-10   GNU C Library: Shared libraries an
ii  libncurses5               5.3.20030719-4 Shared libraries for terminal hand
ii  libssl0.9.6               0.9.6l-1       SSL shared libraries (old version)

-- no debconf information

Reply to: