[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please recompile packages against libmysqlclient12.



Quoting Wichert Akkerman (wichert@wiggy.net):
> Previously Marek Habersack wrote:
> > What about a case as mine - Pike 7.4 is MPL/GPL/LGPL. How does that look in
> > this situation?
> You might get away with the MPL/LGPL options, but you should probably
> ask for confirmation on debian-legal.

So, what *am* I supposed to do? Rebuild against libmysqlclient12
and break licenses? Not rebuild and have an uninstallable snort-mysql? 

This same situation occurred back when I still maintained GnomeMeeting.
GnomeMeeting linked against libopenh323 and libpt, and one of those
linked OpenSSL which resulted in GnomeMeeting depending on OpenSSL.
Afaik this is still the case with GnomeMeeting. So GM is violating a
license too, right?

Should we massively ask permission to explicitly link against OpenSSL
from the OpenSSL upstream? It was something like that, right? You were
supposed to ask permission to link against OpenSSL.

ugh,
Sander.

-- 
| Age is a very high price to pay for maturity.
| 1024D/08CEC94D - 34B3 3314 B146 E13C 70C8  9BDB D463 7E41 08CE C94D

Attachment: pgpcrKqEaq8mG.pgp
Description: PGP signature


Reply to: