[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#163438: flick_2.1-2(hppa/unstable): FTBFS: missing rules in makefile?

lamont+buildd@hp.com writes:

> Package: flick
> Version: 2.1-2
> Severity: serious
> There was an error while trying to autobuild your package:
> A full build log can be found at:
> http://buildd.debian.org/build.php?arch=hppa&pkg=flick&ver=2.1-2

Hmm, looks like config.{guess,sub} could use an update.

But why does the autobuilder invoke `debian/rules build' when Policy
section 7.6 clearly says you need Build-Depends-Indep for that:

  [1]  If you make "build-arch" or "binary-arch", you need Build-Depends.  If
       you make "build-indep" or "binary-indep", you need Build-Depends and
       Build-Depends-Indep.  If you make "build" or "binary", you need both.

I mean, I can make "build" a no-op instead of depending on "build-arch"
and "build-indep", but either Policy or buildd should get fixed.



Reply to: