[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#128444: zope-zpatterns_0.4.3p2-0.2(unstable/sparc): build-depends on a package with interactive install

severity 128444 normal

On 9 Jan 2002, Thomas Bushnell, BSG wrote:

> James Troup <james@nocrew.org> writes:
> > Please don't build-depend on zope, it's postinst is interactive which
> > means it can't be installed by build daemons.  Gregor suggested a
> > better solution in #86722 (namely that the needed header files be
> > copied to zope-zpatterns source), please use that instead.
> I grant that this is a better solution, but it's not clear to me why
> it's "serious".  Policy doesn't have any such rule at present.
> (Though, indeed, I would supporting adding such a rule.)

I do agree with Thomas:
- it's currently perfectly legal for a package to have an interactive
- it's also allowed to build depend on a package with an interactive

I do understand the problems for autobuilders and it should ideally be
fixed but IMHO it's not a RC bug in zope-zpatterns.


Reply to: