[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#126338: gadfly: import gadfly from python2.1 prompt results in a traceback

Package: gadfly
Version: 1.0-7.1
Severity: grave
Justification: renders package unusable

When I do "import gadfly" from python2.1 prompt I get the following

Python 2.1.1+ (#1, Dec 21 2001, 01:01:30) 
[GCC 2.95.4 20011006 (Debian prerelease)] on linux2
Type "copyright", "credits" or "license" for more information.
>>> import gadfly
/usr/lib/python2.1/site-packages/kjParser.py:16: DeprecationWarning: the regex module is deprecated; please use the re module
  import regex
/usr/lib/python2.1/regsub.py:15: DeprecationWarning: the regsub module is deprecated; please use re.sub()
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.1/site-packages/gadfly.py", line 5, in ?
    sql = sqlgen.getSQL()
  File "/usr/lib/python2.1/site-packages/sqlgen.py", line 77, in getSQL
    return reloadSQLG(filename)
  File "/usr/lib/python2.1/site-packages/sqlgen.py", line 69, in reloadSQLG
    infile = open(filename, "rb")
IOError: [Errno 2] No such file or directory: '/usr/lib/python1.5/site-packages/sql.mar'

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux viking.tagancha.org 2.4.16-pre1 #1 Sun Nov 25 11:24:13 EST 2001 i686
Locale: LANG=ru_RU.KOI8-R, LC_CTYPE=ru_RU.KOI8-R

Versions of packages gadfly depends on:
ii  python                        2.1.1-6    An interactive object-oriented scr

Reply to: