[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#126338: marked as done (gadfly: import gadfly from python2.1 prompt results in a traceback)

Your message dated Mon, 24 Dec 2001 15:23:22 -0500
with message-id <E16Ibd4-000179-00@auric.debian.org>
and subject line Bug#126338: fixed in gadfly 1.0-7.2
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 24 Dec 2001 06:02:33 +0000
>From malex@purdue.edu Mon Dec 24 00:02:33 2001
Return-path: <malex@purdue.edu>
Received: from pvil-a-143.resnet.purdue.edu (viking.tagancha.org) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 16IOBv-0005yW-00; Mon, 24 Dec 2001 00:02:28 -0600
Received: from malex by viking.tagancha.org with local (Exim 3.33 #1 (Debian))
	id 16IOCB-0000Ks-00; Mon, 24 Dec 2001 01:02:43 -0500
From: Oleksandr Moskalenko <malex@tagancha.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gadfly: import gadfly from python2.1 prompt results in a traceback
X-Reportbug-Version: 1.41.142
X-Mailer: reportbug 1.41.142
Date: Mon, 24 Dec 2001 01:02:43 -0500
Message-Id: <E16IOCB-0000Ks-00@viking.tagancha.org>
Delivered-To: submit@bugs.debian.org

Package: gadfly
Version: 1.0-7.1
Severity: grave
Justification: renders package unusable

When I do "import gadfly" from python2.1 prompt I get the following

Python 2.1.1+ (#1, Dec 21 2001, 01:01:30) 
[GCC 2.95.4 20011006 (Debian prerelease)] on linux2
Type "copyright", "credits" or "license" for more information.
>>> import gadfly
/usr/lib/python2.1/site-packages/kjParser.py:16: DeprecationWarning: the regex module is deprecated; please use the re module
  import regex
/usr/lib/python2.1/regsub.py:15: DeprecationWarning: the regsub module is deprecated; please use re.sub()
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/lib/python2.1/site-packages/gadfly.py", line 5, in ?
    sql = sqlgen.getSQL()
  File "/usr/lib/python2.1/site-packages/sqlgen.py", line 77, in getSQL
    return reloadSQLG(filename)
  File "/usr/lib/python2.1/site-packages/sqlgen.py", line 69, in reloadSQLG
    infile = open(filename, "rb")
IOError: [Errno 2] No such file or directory: '/usr/lib/python1.5/site-packages/sql.mar'

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux viking.tagancha.org 2.4.16-pre1 #1 Sun Nov 25 11:24:13 EST 2001 i686
Locale: LANG=ru_RU.KOI8-R, LC_CTYPE=ru_RU.KOI8-R

Versions of packages gadfly depends on:
ii  python                        2.1.1-6    An interactive object-oriented scr

Received: (at 126338-close) by bugs.debian.org; 24 Dec 2001 21:01:17 +0000
>From troup@auric.debian.org Mon Dec 24 15:01:17 2001
Return-path: <troup@auric.debian.org>
Received: from auric.debian.org [] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 16IcDl-0000TT-00; Mon, 24 Dec 2001 15:01:17 -0600
Received: from troup by auric.debian.org with local (Exim 3.12 1 (Debian))
	id 16Ibd4-000179-00; Mon, 24 Dec 2001 15:23:22 -0500
From: Matthias Klose <doko@debian.org>
To: 126338-close@bugs.debian.org
X-Katie: $Revision: 1.66 $
Subject: Bug#126338: fixed in gadfly 1.0-7.2
Message-Id: <E16Ibd4-000179-00@auric.debian.org>
Sender: James Troup <troup@auric.debian.org>
Date: Mon, 24 Dec 2001 15:23:22 -0500
Delivered-To: 126338-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
gadfly, which has been installed in the Debian FTP archive:

  to pool/main/g/gadfly/gadfly_1.0-7.2.diff.gz
  to pool/main/g/gadfly/gadfly_1.0-7.2.dsc
  to pool/main/g/gadfly/gadfly_1.0-7.2_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 126338@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Matthias Klose <doko@debian.org> (supplier of updated gadfly package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


Format: 1.7
Date: Mon, 24 Dec 2001 13:10:27 +0100
Source: gadfly
Binary: gadfly
Architecture: source all
Version: 1.0-7.2
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Matthias Klose <doko@debian.org>
 gadfly     - SQL database and parser generator in Python
Closes: 125857 126338
 gadfly (1.0-7.2) unstable; urgency=low
   * Fix postinst to use Debian's python2.1 (closes: #125857).
   * Fix location of sql.mar file (closes: #126338).
 99a6b08471d0d88bba79147d43a8ddaa 925 interpreters optional gadfly_1.0-7.2.dsc
 0f4d796c7dfff39dc27078f4fde5056a 4049 interpreters optional gadfly_1.0-7.2.diff.gz
 6ea31a482065ea9495daf54e17f828fd 183310 interpreters optional gadfly_1.0-7.2_all.deb

Version: 2.6.3ia
Charset: noconv
Comment: Requires PGP version 2.6 or later.


Reply to: