[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Thoughts on apps supporting multiple versions of python

Le samedi 29 avril 2006 à 18:28 -0300, Gustavo Noronha Silva a écrit :
> That means I'll have whatever python version is the default one, since
> python-gtk2 is supposed to depend on python2.3-gtk2, and will switch to
> python2.4-gtk2. So I'm guaranteeing gazpacho will work, but I'll also
> have the following situation: gazpacho supports python2.4 but will only
> run with that version if python2.4-gtk2 is installed.

I don't understand how this is an issue for a package like gazpacho.

This can become a problem if a module package python-foo uses
python-support and requires python-gtk2. In this case, the package using
python-foo has to depend python2.4-gtk2 even if it doesn't use gtk2

 .''`.           Josselin Mouette        /\./\
: :' :           josselin.mouette@ens-lyon.org
`. `'                        joss@debian.org
  `-  Debian GNU/Linux -- The power of freedom

Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=

Reply to: