[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Thoughts on apps supporting multiple versions of python


Today I was playing with the idea of having gazpacho support multiple
versions of Python. Nothing really forbids it, since it doesn't use
anything that is specific to python2.4, for example.

So I added gazpacho's module under python-support's control and made it
not Depend on python >= 2.3 and python << 2.4. I have only:

Depends: python-gtk2 (>= 2.6.0), python-support

That means I'll have whatever python version is the default one, since
python-gtk2 is supposed to depend on python2.3-gtk2, and will switch to
python2.4-gtk2. So I'm guaranteeing gazpacho will work, but I'll also
have the following situation: gazpacho supports python2.4 but will only
run with that version if python2.4-gtk2 is installed.

Maybe we need a way of telling python-support that 'I can run with the
following versions, but will only be able to do that if this package
supports them'.

Also, to make python-gtk2 support more than one version, we could only
achieve that by providing the extensions in a single package or building
them on install time. Has anyone thought about this?

See you,

Gustavo Noronha Silva <kov@debian.org>

Attachment: signature.asc
Description: Esta =?ISO-8859-1?Q?=E9?= uma parte de mensagem assinada digitalmente

Reply to: