[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#935918: marked as done (cups: can't read hpcups PPDs)

Your message dated Wed, 02 Oct 2019 11:25:51 +0200
with message-id <[🔎] 1735093.bI5nPUV3X6@odyx.org>
and subject line Re: Bug#935918: cups: can't read hpcups PPDs
has caused the Debian Bug report #935918,
regarding cups: can't read hpcups PPDs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

935918: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=935918
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: cups
Version: 2.2.12-1


Today I was unable to print on a HP Envy 5030 connected with USB that
used to work perfectly. The error message in CUPS web interface was
"filter failed" or something (from memory).

Not able to find the problem, I tried to reinstall the printer;
curiously, it worked with hpijs but not with hpcups. The error message
was "Unable to copy PPD file" (again from memory).

Using the hpijs driver was not satisfying because the printing is not
centered (in CUPS test page, the upper and right-most frame borders are
missing, even after setting paper size to A4 from the default Letter),
and it can't be corrected because the options are very limited, so I was
determined to find why adding the printer with the hpcups driver was not

Adding it through HP ToolBox (from hplip) failed too, with an error
message I don't remember.

Adding it manually with lpadmin failed too, but with a much more
explicit message:

raph@arche:~$ LANG=C sudo lpadmin -p HP_ENVY_5030 -v
"usb://HP/ENVY%205000%20series?serial=redacted&interface=1" -m
"drv:///hpcups.drv/hp-envy_5000_series.ppd" -D "HP Envy 5030"

lpadmin: Unable to open PPD "/tmp/0587f5d6ca5c8": Illegal option keyword
string on line 198.

Line 198 reads:

*PageSize Custom/Custom: "<</cupsInteger0 101/PageSize [612
1008]/ImagingBBox null>>setpagedevice"

Googling some more, I found a very recent thread on the ArchLinux forum
which described exactly the same problem:


Unlike this Arch user, I didn't want to fiddle with the PPD (more
precisely, it may seem silly, but I stalled because I wasn't sure about
what I could replace the word "Custom" with...)

So instead I downgraded all cups packages from 2.2.12-1 to 2.2.10-6 and
that solved the problem completely (long live snapshot.debian.org), I
could add the printer with the hpcups driver and print documents as

Aside from that, other reasons that make me think that the problem comes
from the cups upgrade and not from printer-driver-hpcups are:

- the generated PPDs are identical (on failure, lpadmin left it in /tmp;
I compared it to the one in /etc/cups/ppd generated after the downgrade)

- cups was upgraded very recently (08/18 according to apt log) whereas
printer-driver-hpcups was not upgraded since I installed my Sid box
(06/06) and I clearly remember printing without problems between those dates

I was tempted to file this bug with a high severity since it prevents
installing a printer or simply printing, but since it also seems limited
to hpcups, I'll let you decide on this.


Raphaël Halimi

Attachment: signature.asc
Description: OpenPGP digital signature

--- End Message ---
--- Begin Message ---
Le mercredi, 2 octobre 2019, 10.15:29 h CEST Raphaël Halimi a écrit :
> After upgrading hplip to 3.19.8+dfsg0-7 and re-adding the printer, I can
> confirm that the problem is fixed, at least for my printer.

Let's close that bug then, thanks for the feedback!


Attachment: signature.asc
Description: This is a digitally signed message part.

--- End Message ---

Reply to: