[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#585627: hplip: Error with hpmudext module : hp-* dont works

severity 585627 normal
tags 585627 confirmed experimental
affects 585627 python

On Saturday 12 June 2010 23:32:32 Eloi COUTANT wrote:
> When i try to launch hp-* commands (hp-clean, hp-check, hp-align,
> hp-toolbox), i have this error :
> $# hp-clean
> Traceback (most recent call last):
>   File "/usr/bin/hp-clean", line 38, in <module>
>     from base import device, utils, maint, tui, module
>   File "/usr/share/hplip/base/device.py", line 37, in <module>
>     import status
>   File "/usr/share/hplip/base/status.py", line 40, in <module>
>     import hpmudext
> ImportError: No module named hpmudext


I can reproduce this report if I install python 2.6 from experimental, which 
you appear to have installed.  Using packages from experimental is not a 
supported configuration. Debian unstable hplip has been built with python 2.5:

If you have a look inside the hplip package you will see we install to:

As a workaround, please do the following:

# apt-get install python/unstable python-minimal/unstable

> Checking Python version...
> OK, version 2.6.5 installed

Debian unstable supported python version is: 2.5.4-9

Matthias, What foo should I put in my debian/control file to automatically 
generate the correct depends:

We currently just have:
XB-Python-Version: ${python:Versions}
Depends: ${python:Depends}, python-dbus (>= 0.80), python-imaging, python-pexpect, python-notify

But that doesn't limit the Depends to the python version the package was built with.

It seems that I could hard code:
XS-Python-Version: 2.5

But that would be too much and the package would then have to be manually 
updated every-time you upversion python.


Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: