[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#423972: update to 1.2.11-1 prevents remote printing



On Tue, 15 May 2007 15:20:23 +0200
Martin Pitt <mpitt@debian.org> wrote:

> Hi,
>
> Kenshi Muto [2007-05-15 16:53 +0900]:
> > Could you try "chmod 755 /usr/lib/cups/backend/ipp"?
>
> Whoops, indeed this is doomed to fail, the file is 0700 now. I'll fix
> that in the next upload. Can you please confirm that this fixes it?

sudo apt-get upgrade
(re-installs the versions of cupsys and cupsys-common from unstable)

sudo chmod 0755 /usr/lib/cups/backend/ipp

Everything is working again.

-rwxr-xr-x 3 root root 24856 2007-05-14 09:57 /usr/lib/cups/backend/ipp

Hmmm - I wish the error message was a little more descriptive. Something this simple should be clearer from the error_log. Maybe add something like "permission denied: backend is not readable" or "cannot execute backend/ipp" ?

Anything is better than:
stopped with status 22!

:-)

--


Neil Williams
=============
http://www.data-freedom.org/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpl8sY44wVwP.pgp
Description: PGP signature


Reply to: